Bug 1336480
| Summary: | cant install Image Magick due to OSE dependencies | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Eric Rich <erich> |
| Component: | Build | Assignee: | Abhishek Gupta <abhgupta> |
| Status: | CLOSED ERRATA | QA Contact: | Gaoyun Pei <gpei> |
| Severity: | high | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 2.2.0 | CC: | aos-bugs, bparees, erich, gpei, rthrashe |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2016-05-19 20:02:44 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Eric is this really for openshift v2? (In reply to Ben Parees from comment #1) > Eric is this really for openshift v2? Yes v2, so over to Abhishek. We're looking to do an async release to deal with a number of dependency issues, including Image Magick. http://etherpad.corp.redhat.com/puddle-2-2-2016-05-16 QE, This testing should be the same process as bug 1336485 - with a focus on ImageMagick. Could we please test that the following list using the above puddle? 1) Ensure a complete installation succeeds without dependency issues 2) Install the openshift-origin-cartridge-dependencies-optional-* packages if they were not already installed and ensure the installation succeeds without dependency issues: # yum install openshift-origin-cartridge-dependencies-optional-* 3) Ensure that ImageMagick can be installed successfully /after/ installing the openshift-origin-cartridge-dependencies-optional packages: # yum install ImageMagick 4) Ensure that ImageMagick, icu, yum-utils, and php versions installed match the below: # rpm -qa | grep -e ImageMagick -e icu -e "yum-utils" -e "php-5" ImageMagick-6.7.2.7-4 icu-4.2.1-14 yum-utils-1.1.30-37 php-5.3.3-47 Thank you! Move this bug to verified according to https://bugzilla.redhat.com/show_bug.cgi?id=1336485#c4 Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2016-1093.html |
Description of problem: # yum install ImageMagick.x86_64 ImageMagick.i686 ... Resolving Dependencies --> Running transaction check ---> Package ImageMagick.x86_64 0:6.7.2.7-2.el6 will be updated --> Processing Dependency: ImageMagick = 6.7.2.7-2.el6 for package: ImageMagick-perl-6.7.2.7-2.el6.x86_64 --> Processing Dependency: ImageMagick = 6.7.2.7-2.el6 for package: ImageMagick-devel-6.7.2.7-2.el6.x86_64 ---> Package ImageMagick.i686 0:6.7.2.7-4.el6_7 will be installed ... Error: Package: ImageMagick-devel-6.7.2.7-2.el6.x86_64 (@rhel-6-server-ose-2.2-node-rpms) Requires: ImageMagick = 6.7.2.7-2.el6 Removing: ImageMagick-6.7.2.7-2.el6.x86_64 (@rhel-6-server-rpms) ImageMagick = 6.7.2.7-2.el6 Updated By: ImageMagick-6.7.2.7-4.el6_7.x86_64 (rhel-6-server-rpms) ImageMagick = 6.7.2.7-4.el6_7 Version-Release number of selected component (if applicable): 2.2 How reproducible: 100% Steps to Reproduce: 1. yum install ImageMagick.x86_64 ImageMagick.i686 - You need to have RHEL and OpenShift channels setup Actual results: Denoted errors (above) Expected results: Prompt to install packages. Additional info: