Bug 1336530 - no warning about to-be-removed packages before upgrade
Summary: no warning about to-be-removed packages before upgrade
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software   
(Show other bugs)
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1308538
TreeView+ depends on / blocked
 
Reported: 2016-05-16 18:18 UTC by Kamil Páral
Modified: 2016-07-20 23:50 UTC (History)
4 users (show)

Fixed In Version: gnome-software-3.20.4-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 23:50:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qa in F23 (51.63 KB, text/plain)
2016-05-16 18:19 UTC, Kamil Páral
no flags Details
rpm -qa in F24 (53.34 KB, text/plain)
2016-05-16 18:19 UTC, Kamil Páral
no flags Details
upgrade.journal (986.35 KB, text/plain)
2016-05-16 18:20 UTC, Kamil Páral
no flags Details
offline-status in F24 (65.14 KB, text/plain)
2016-05-16 18:20 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2016-05-16 18:18:55 UTC
Description of problem:
https://fedoraproject.org/wiki/QA:Testcase_Workstation_Graphical_Upgrade says:
" There should be warnings if you had RPMs installed before the upgrade that would be broken by the upgrade (e.g. 3rd party software). "

Also, our release criteria say:
" The upgraded system must include all packages that would be present on the system after a default installation from install media, plus any packages the user previously had (minus any obsolete content). "
https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria#Upgrade_requirements

Which is trying to imply that if you're going to remove any user-installed packages, the user needs to give her consent to this, otherwise the upgrade should not proceed. This is to prevent a situation when an app essential for the user suddenly becomes unavailable (and often uninstallable) after upgrading to a more recent Fedora release. dnf-plugin-system-upgrade does this, it prints which packages are going to be removed and the user needs to confirm it. gnome-software currently doesn't.

If there are any packages to be removed (I think it could show only the user-installed ones by default if you want, but it would be good to present a full list after some expander), please let the user confirm the decision first (ideally before downloading all the packages). 

Version-Release number of selected component (if applicable):
gnome-software-3.20.3-0.191.20160425git.fc23.x86_64
PackageKit-1.1.1-1.fc23.x86_64
libhif-0.2.3-0.145.20160427git.fc23.x86_64

How reproducible:
I guess always, but tried once

Steps to Reproduce:
1. into a fully updated F23 add rpmfusion repos and install vlc, ffmpeg, gstreamer1-libav, lame, steam (or use something else which is going to have some broken deps during the upgrade)
2. in GNOME Software click Download upgrade, see no warning
3. click Install upgrade, see no warning
4. after upgrade, check your packages in F24. In my case, vlc, ffmpeg and gstreamer1-libav was missing (removed due to unsatisfied deps), lame and steam was present.

Actual results:
packages are removed without user consent

Expected results:
packages are not removed without user consent

Comment 1 Kamil Páral 2016-05-16 18:19:52 UTC
Created attachment 1158070 [details]
rpm -qa in F23

Comment 2 Kamil Páral 2016-05-16 18:19:58 UTC
Created attachment 1158071 [details]
rpm -qa in F24

Comment 3 Kamil Páral 2016-05-16 18:20:08 UTC
Created attachment 1158072 [details]
upgrade.journal

Comment 4 Kamil Páral 2016-05-16 18:20:14 UTC
Created attachment 1158073 [details]
offline-status in F24

Comment 5 Matthias Clasen 2016-05-16 18:57:08 UTC
The initial design

https://raw.githubusercontent.com/gnome-design-team/gnome-mockups/master/software
/old/version2/wire-upgrades.png

has guidance for this eventuality.

Comment 7 Fedora Update System 2016-07-12 19:14:19 UTC
PackageKit-1.1.2-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-1.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 8 Fedora Update System 2016-07-12 19:14:37 UTC
PackageKit-1.1.2-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-1.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 9 Kamil Páral 2016-07-13 12:27:53 UTC
This seems fixed with updates from comment 8.

Comment 10 Fedora Update System 2016-07-14 01:25:02 UTC
PackageKit-1.1.2-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-1.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 11 Fedora Update System 2016-07-14 13:27:53 UTC
PackageKit-1.1.3-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-2.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 12 Fedora Update System 2016-07-15 17:52:32 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 13 Fedora Update System 2016-07-20 23:49:33 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.