Bug 1336558 - License metadata does not match actual license of code
Summary: License metadata does not match actual license of code
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpcbind
Version: 6.9
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks: 1507140
TreeView+ depends on / blocked
 
Reported: 2016-05-16 21:13 UTC by Iliana Weller
Modified: 2018-06-29 04:44 UTC (History)
9 users (show)

Fixed In Version: rpcbind-0.2.0-16.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-19 05:20:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1901 None None None 2018-06-19 05:20:40 UTC

Description Iliana Weller 2016-05-16 21:13:38 UTC
rpcbind is incorrectly labeled as GPL, when the actual license is BSD.

This appears to only be an issue in RHEL 6; RHEL 7's rpcbind has the correct license tag.

$ rpm -q rpcbind
rpcbind-0.2.0-12.el6.x86_64
$ rpm -qi rpcbind | grep License
License: GPL
$ cat rpcbind-0.2.0/COPYING
/*
 * Copyright (c) Copyright (c) Bull S.A. 2005 All Rights Reserved.
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 * 1. Redistributions of source code must retain the above copyright
 * notice, this list of conditions and the following disclaimer.
 * 2. Redistributions in binary form must reproduce the above copyright
 * notice, this list of conditions and the following disclaimer in the
 * documentation and/or other materials provided with the distribution.
 * 3. The name of the author may not be used to endorse or promote products
 * derived from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
 * IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
 * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
 * IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
 * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
 * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
 * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
 * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
 * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
 * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

Comment 3 Steve Dickson 2016-08-25 15:05:07 UTC
commit 0f199dfa0f7feac224e9c202b591f69be458e81e
Author: Tom Callaway <spot@fedoraproject.org>
Date:   Fri Jul 16 18:00:47 2010 +0000

    fix license tag

Comment 4 Steve Whitehouse 2017-02-09 15:45:55 UTC
Can we have a QA ack for this bug?

Comment 10 Steve Whitehouse 2017-12-01 10:35:36 UTC
Can we get this fixed now? It seems to be a trivial fix, and I agree that it should be corrected.

Comment 11 Steve Dickson 2017-12-01 14:03:50 UTC
(In reply to Steve Whitehouse from comment #10)
> Can we get this fixed now? It seems to be a trivial fix, and I agree that it
> should be corrected.

No PM acks...

Comment 14 Yongcheng Yang 2018-03-20 08:04:27 UTC
Moving to VERIFIED according to comment #13.

Will keep an eye on this regression case.

Comment 17 errata-xmlrpc 2018-06-19 05:20:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1901

Comment 18 Ryan Estep 2018-06-28 14:38:42 UTC
When updating a RHEL 6 system to the 2.6.32-754.el6.x86_64 kernel, rpcbind failed to start after reboot.  I had to manually start the service, despite having it turned on in chkconfig.

Comment 19 Ryan Estep 2018-06-28 14:47:50 UTC
The version of the package that I was updating rpcbind to was rpcbind-0.2.0-16.el6.x86_64.

Comment 20 Yongcheng Yang 2018-06-29 04:44:04 UTC
(In reply to Ryan Estep from comment #18)
> When updating a RHEL 6 system to the 2.6.32-754.el6.x86_64 kernel, rpcbind
> failed to start after reboot.  I had to manually start the service, despite
> having it turned on in chkconfig.

I cannot reproduce the above issue.

Please go ahead to open another bug if it's reproducible. Thanks!

My test logs:
~~~~~~~~~~~~~
[root@test-rhel6 ~]# rpm -q rpcbind
rpcbind-0.2.0-13.el6.x86_64
             ^^^^
[root@test-rhel6 ~]# yum update -y rpcbind >/dev/null
[root@test-rhel6 ~]# rpm -q rpcbind
rpcbind-0.2.0-16.el6.x86_64
             ^^^^
[root@test-rhel6 ~]# chkconfig --list | grep rpcbind
rpcbind         0:off   1:off   2:on    3:on    4:on    5:on    6:off
[root@test-rhel6 ~]# chkconfig rpcbind on
[root@test-rhel6 ~]# chkconfig --list | grep rpcbind
rpcbind         0:off   1:off   2:on    3:on    4:on    5:on    6:off
[root@test-rhel6 ~]# reboot
The system is going down for reboot NOW!
...
[yoyang@yoyang-pc ~]$ ssh test-rhel6.redhat.com
[root@test-rhel6 ~]# service rpcbind status
rpcbind (pid  2171) is running...
[root@test-rhel6 ~]# rpm -q rpcbind
rpcbind-0.2.0-16.el6.x86_64
[root@test-rhel6 ~]# rpm -q kernel
kernel-2.6.32-754.el6.x86_64
[root@test-rhel6 ~]#


Note You need to log in before you can comment on or make changes to this bug.