Bug 133657 - Add/Remove Applications fails to access install CDs
Add/Remove Applications fails to access install CDs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-25 16:31 EDT by Leon Stringer
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 14:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Command line output of system-config-packages with new method.py (7.50 KB, text/plain)
2004-10-01 16:19 EDT, Leon Stringer
no flags Details
System-config-packages output with test method.py (7.74 KB, text/plain)
2004-10-02 11:44 EDT, Leon Stringer
no flags Details

  None (edit)
Description Leon Stringer 2004-09-25 16:31:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
I've just installed FC3t2. I now want to install some additional
packages. So I've opened the Add/Remove Applications window, selected
my new
packages and clicked Update. I then got a message telling me to insert
Disc 1 which I've done and I then get the error "Unable to access
disk.".

(The CD auto mounts, is readable and I did a media check before
installation, it was fine).

Version-Release number of selected component (if applicable):
1.2.16-2

How reproducible:
Always

Steps to Reproduce:
1. Select System Settings->Add/Remove Applications
2. Select some additional applications (e.g. Web Server).
3. Click Update.
4. The changes are processed and the required discs listed.
5. Insert the CD when prompted and click OK.

    

Actual Results:  The message "Unable to access disk." is displayed

Expected Results:  The packages should be installed from the CD.

Additional info:

I posted this to fedora-test-list and at least one other user has this
issue.
Comment 1 Leon Stringer 2004-09-26 07:13:26 EDT
I've tested this with system-config-packages-1.2.17-1, same problem.
Comment 2 Jeremy Katz 2004-09-27 13:11:44 EDT
What version of hal, dbus-python and gnome-volume-manager do you have
installed?  Can you grab 1.2.18 from
http://people.redhat.com/~katzj/system-config-packages/ and see if it
does better?
Comment 3 Leon Stringer 2004-09-27 14:35:38 EDT
In short: No, it's no better.

I've updated the packages you mentioned so I've now got:

system-config-packages-1.2.18-1
hal-0.2.98.cvs20040923-1
dbus-python-0.22-9
gnome-volume-manager-0.9.10-2

I didn't do any timing tests but I'm sure that originally I got the
"Unable to access disk." message as soon as I clicked OK when prompted
for the CD. Now there's a 3 second delay (although it does not appear
to access the CD drive during this time).
Comment 4 Jeremy Katz 2004-09-30 16:36:19 EDT
Can you grab http://people.redhat.com/~katzj/method.py and place it in
/usr/share/system-config-packages/ and then run s-c-p from the command
line and see what it outputs?
Comment 5 Leon Stringer 2004-10-01 16:19:08 EDT
Created attachment 104647 [details]
Command line output of system-config-packages with new method.py

As requested here is the output with the modified method.py.

The same problem occurs.

hda is the CD drive, here's the entry from /etc/fstab:
/dev/hda		/media/cdrw_dvdrom	auto   
noauto,user,exec,kudzu,ro 0 0
Comment 6 Jeremy Katz 2004-10-01 16:26:59 EDT
Just put a new method.py up at the same location with more debugging
in the appropriate areas.  Can you try with it?
Comment 7 Leon Stringer 2004-10-02 11:44:23 EDT
Created attachment 104667 [details]
System-config-packages output with test method.py
Comment 8 Jeremy Katz 2004-10-04 09:48:27 EDT
Okay, I think I see what is going on.  Should be fixed in 1.2.19. 
(Will be up at http://people.redhat.com/~katzj/redhat-config-packages/
once I build it, 10-15 minutes or so)
Comment 9 Leon Stringer 2004-10-06 16:25:22 EDT
I've now tried 1.2.19 and I'm afraid I still get the same problem.
Comment 10 Leon Stringer 2004-10-21 17:47:14 EDT
I've finally got round to installing FC3t3 and no longer experience
this problem.
Comment 11 Mike 2004-11-11 20:26:01 EST
I have tried this in the latest FC3 release and it is still present. 
I have mounted the ISO image of disk2 to /media/cdrom and the package 
manager fails to find the files even though I did a ls 
on /media/cdrom and see all the contents of the image. I've also 
tried mounting in /mnt/cdrom - same results.

Any idea whats wrong?
Comment 12 Marius Andreiana 2005-08-19 17:03:19 EDT
Mike, would you please test with FC4? 
Thanks in advance
Comment 13 Jeremy Katz 2005-09-21 14:02:18 EDT
Closing due to inactivity.  This should be resolved in current releases

Note You need to log in before you can comment on or make changes to this bug.