Bug 1336639 - RHEV-H: Bond device shows 'Driver: unknown'
Summary: RHEV-H: Bond device shows 'Driver: unknown'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Fabian Deutsch
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 06:14 UTC by Germano Veit Michel
Modified: 2017-03-20 09:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:07:43 UTC
oVirt Team: Network


Attachments (Terms of Use)
Screenshot of the unknown driver for bond devices. (9.05 KB, image/png)
2016-05-17 06:14 UTC, Germano Veit Michel
no flags Details
Screenshot showing the driver location in Cockpit (25.05 KB, image/png)
2016-06-22 15:56 UTC, Fabian Deutsch
no flags Details
screen shot of a bond's driver (61.00 KB, image/png)
2016-06-23 10:35 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1702 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:35:27 UTC

Description Germano Veit Michel 2016-05-17 06:14:31 UTC
Created attachment 1158178 [details]
Screenshot of the unknown driver for bond devices.

Description of problem:

Just a cosmetic issue as all the underlying settings are fine. When a bonding device is configured, the driver is showing as unknown in the Network tab, after entering in the device configuration. See screenshot attached for clarification.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20160413.0.el7ev)

How reproducible:
100%

Steps to Reproduce:
1. Setup Bond using RHEV-H UI
2. Check the status as shown in attachment

Actual results:
NIC details: bond0
Driver: unknown
Link Status: Connected

# ethtool -i bond0 | grep driver
driver: bonding

Expected results:
NIC details: bond0
Driver: bonding
Link Status: Connected

Additional info:
If it's a VLAN (bond0.VID) should be show the 8021q driver?

Comment 1 Fabian Deutsch 2016-05-17 08:05:39 UTC
Thanks for the report.
It looks liek this issue will be fixed in RHEV 4.0, where we are moving to Cockpit for the initial network administration.

Comment 2 Fabian Deutsch 2016-05-17 08:06:21 UTC
However, this will not be fixed in the current text UI.

Comment 3 Michael Burman 2016-06-22 13:14:24 UTC
Hi Fabian,

How can i test it? i don't see any 'Driver' field in the cockpit UI..

Comment 4 Fabian Deutsch 2016-06-22 15:56:47 UTC
Created attachment 1170870 [details]
Screenshot showing the driver location in Cockpit

Yes - There is no explicit driver field, but the driver is shown alongside the NIC name - see the attached screenshot for the exact location.

Comment 5 Michael Burman 2016-06-23 07:07:45 UTC
Thank you Fabian) i will test it.

Comment 6 Michael Burman 2016-06-23 10:35:13 UTC
Created attachment 1171410 [details]
screen shot of a bond's driver

Comment 7 Michael Burman 2016-06-23 10:37:51 UTC
I'm not this is what i expected to see, i don't see the driver info for the bond NIC.
Is the the 'Bond'? isn't should be 'bonding'? 
Attaching screen shot from cockpit-0.108-1.el7.x86_64 ^^

Comment 8 Fabian Deutsch 2016-06-23 13:25:33 UTC
To me "Bond" or "bonding" is sufficient.

The driver of the underlying bond slaves is not shown, because there can be a large number of underlying slaves with different drivers (which should not be done, because it can be unstable).

To me it is sufficient that "Bond" is shown instead of "unknown".

Comment 9 Michael Burman 2016-06-23 13:47:06 UTC
Verified on - cockpit-0.108-1.el7.x86_64

Comment 11 errata-xmlrpc 2016-08-23 21:07:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1702.html


Note You need to log in before you can comment on or make changes to this bug.