Bug 133670 - sensors-detect does not use devfs
sensors-detect does not use devfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-25 20:26 EDT by Adam Wiggins
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version: lm_sensors-2.8.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 10:06:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Wiggins 2004-09-25 20:26:31 EDT
Running sensors-detect produces the error: 
 
No i2c device files found. Use prog/mkdev/mkdev.sh to create them. 
 
I debugged the script and noticed that it was not setting $use_devfs 
even though it is my understanding that FC3 uses it.  It seems to be 
scanning /proc/mounts for the string "devfs" but mine does not 
contain it, as follows: 
 
rootfs / rootfs rw 0 0 
/proc /proc proc rw,nodiratime 0 0 
none /dev tmpfs rw 0 0 
/dev/root / ext3 rw 0 0 
none /dev tmpfs rw 0 0 
none /selinux selinuxfs rw 0 0 
/proc /proc proc rw,nodiratime 0 0 
/proc/bus/usb /proc/bus/usb usbfs rw 0 0 
/sys /sys sysfs rw 0 0 
none /dev/pts devpts rw 0 0 
none /dev/shm tmpfs rw 0 0 
/dev/hda3 /home ext3 rw 0 0 
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0 
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0 
nfsd /proc/fs/nfsd nfsd rw 0 0 
 
I modifed the script by adding inserting $use_devfs = 1; at line 
1786, and then it worked. 
 
Side comment: this is my first time using lm_sensors, but I was 
surprised how difficult it was to set up.  I guess by the old time 
do-it-yourself Linux standards it's easy (run a few scripts, press 
enter a lot at a bunch of questions I don't really understand, 
cut-n-paste some text into a file) but by the new, 
everything-just-works standard that Fedora and other modern distros 
use it seems like a lot of busywork.  Shouldn't sensors-detect run at 
install time, answering all the questions with their defaults 
automatically, and setting the appropriate modules to load?  Or at 
the very least, have an /etc/init.d/lm_sensors script which has an 
"init" option that does all of this.

Note You need to log in before you can comment on or make changes to this bug.