Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1336700 - Missing packages - openstack-tripleo-heat-templates-0.8.14-11 and openstack-tripleo-heat-templates-0.8.14-11
Summary: Missing packages - openstack-tripleo-heat-templates-0.8.14-11 and openstack-t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 08:53 UTC by Rafal Szmigiel
Modified: 2016-05-18 12:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-18 12:27:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rafal Szmigiel 2016-05-17 08:53:50 UTC
Description of problem:

Due to the missing RPMs I cannot install python-tripleoclient. This has been verified and confirmed by Karim Latouche as well in his independent environment. 

Version-Release number of selected component (if applicable):



How reproducible:

[root@director ~]# rm -fr /var/cache/yum/*


[root@director ~]# yum clean all 
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Cleaning repos: rhel-7-server-extras-rpms rhel-7-server-openstack-8-director-rpms rhel-7-server-openstack-8-rpms rhel-7-server-rh-common-rpms rhel-7-server-rpms
Cleaning up everything


[root@director ~]# yum install -y python-tripleoclient
Loaded plugins: product-id, search-disabled-repos, subscription-manager
rhel-7-server-extras-rpms                                                                                                                                                                                              | 2.9 kB  00:00:00     
rhel-7-server-openstack-8-director-rpms                                                                                                                                                                                | 4.0 kB  00:00:00     
rhel-7-server-openstack-8-rpms                                                                                                                                                                                         | 4.0 kB  00:00:00     
rhel-7-server-rh-common-rpms                                                                                                                                                                                           | 3.8 kB  00:00:00     
rhel-7-server-rpms                                                                      

(...)

(35/119): openstack-heat-templates-0-0.1.20151019.el7ost.noarch.rpm                                                                                                                                                    |  62 kB  00:00:00     
(36/119): openstack-tripleo-common-0.3.1-1.el7ost.noarch.rpm                                                                                                                                                           |  29 kB  00:00:00     
(37/119): openstack-tripleo-0.0.7-1.el7ost.noarch.rpm                                                                                                                                                                  |  71 kB  00:00:00     
openstack-tripleo-heat-templat FAILED                                          
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack-director/8/os/Packages/openstack-tripleo-heat-templates-kilo-0.8.14-11.el7ost.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found ] 1.3 MB/s | 6.5 MB  00:00:11 ETA 
Trying other mirror.
To address this issue please refer to the below knowledge base article 

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

openstack-tripleo-heat-templat FAILED                                          
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack-director/8/os/Packages/openstack-tripleo-heat-templates-0.8.14-11.el7ost.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found      ] 1.3 MB/s | 6.5 MB  00:00:11 ETA 
Trying other mirror.
(38/119): openstack-tripleo-image-elements-0.9.9-2.el7ost.noarch.rpm                                                                                                                                                   | 418 kB  00:00:00     
(39/119): openstack-tripleo-puppet-elements-0.0.5-1.el7ost.noarch.rpm                                                                                                                                                  |  37 kB  00:00:00     
(40/119): patch-2.7.1-8.el7.x86_64.rpm                                                            

(...)

Error downloading packages:
  openstack-tripleo-heat-templates-0.8.14-11.el7ost.noarch: [Errno 256] No more mirrors to try.
  openstack-tripleo-heat-templates-kilo-0.8.14-11.el7ost.noarch: [Errno 256] No more mirrors to try.




Steps to Reproduce:
1. Install a fresh system
2. Disable/Enable repos as specified in OSP8 Director documentation
3. Request python-tripleoclient to be installed

Actual results:

Two RPMs are missing making python-tripleoclient unable to be installed.

Expected results:

python-tripleoclient is successfully installed 

Additional info:

Comment 2 Mike Burns 2016-05-18 12:27:43 UTC
This was a repodata problem in CDN that has since been resolved.


Note You need to log in before you can comment on or make changes to this bug.