Bug 133677 - X server crashes in FC3T2
Summary: X server crashes in FC3T2
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-26 03:16 UTC by Debo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 18:37:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Debo 2004-09-26 03:16:14 UTC
Description of problem:

Installed FC3T2 on a Dell Precision 360. X server crashes frequently.
Installed Nvidia driver 1.0.6111 .... Every time on boot I need to be
root and manually modprobe the nvidia kernel module else X complains
that kernel module not found. 

Config: precision 360, quadro nvs280, 1GB ram, 40gb HDD, intel eth, p4
2.4G

Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
1. boot
2. login as a non superuser
3. startx
  
Actual results:

X says kernel module not found screens not found

Expected results:

normal Xserver start

Additional info:

Comment 1 Chris Tencati 2004-10-01 10:20:02 UTC
I get this too with nvidia drivers...it seems that nvidia won't setup
the system so kerneld will load the module itself if rivafb is
present.  Apparently rivafb conflicts with nvidia, so if the rivafb
module is present for your kernel (doesn't even need to be loaded),
the nvidia installer won't setup the loading of its own module.  I'm
pretty sure you can just edit the scripts yourself to make sure
kerneld loads it on boot, and it should work then.

Comment 2 Chris Tencati 2004-10-01 14:11:34 UTC
er well, not kerneld per se since it's gone in 2.6 :)  But you should
be able to just add it to /etc/modprobe.conf and have it work.

Comment 3 Søren Sandmann Pedersen 2004-10-06 18:37:22 UTC
As Chris said, you should make sure the module is installed by
/etc/modprobe.conf



Note You need to log in before you can comment on or make changes to this bug.