Bug 1336774 - Segfault locks us out of the servers
Summary: Segfault locks us out of the servers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pam_yubico
Version: el6
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 12:31 UTC by D.S. Ljungmark
Modified: 2016-07-02 23:49 UTC (History)
4 users (show)

Fixed In Version: pam_yubico-2.23-1.fc24 pam_yubico-2.23-1.fc22 pam_yubico-2.23-1.fc23 pam_yubico-2.23-1.el6 pam_yubico-2.23-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-23 17:54:31 UTC


Attachments (Terms of Use)

Description D.S. Ljungmark 2016-05-17 12:31:44 UTC
Description of problem:

Since the update to pam_yubico-2.21-3.el6 +  ykclient-2.15-1.el6 we cannot access our x86_64 bounce server anymore.

This causes some slight issues as we cannot access any of our infrastructure remote, at all.



Version-Release number of selected component (if applicable):
2.21-3.el6 / 2.15-1.el6

How reproducible:
Attempts to ssh into machines without ControlMaster fails


Steps to Reproduce:
1. configure pam_yubico as required
2. install update
3. be locked out of machines

Actual results:
Locked out of  our el6 environments

Expected results:
Functional environments

Additional info:
This is a bit of a headache.

Comment 1 Oliver Haessler 2016-05-17 12:35:43 UTC
Is downgrading pam_yubico helping to solve that issue as a workaround?

Comment 2 D.S. Ljungmark 2016-05-17 13:14:32 UTC
Manually overriding with:

https://kojipkgs.fedoraproject.org//packages/pam_yubico/2.19/1.el6/x86_64/pam_yubico-2.19-1.el6.x86_64.rpm 
https://kojipkgs.fedoraproject.org//packages/ykclient/2.14/1.el6/x86_64/ykclient-2.14-1.el6.x86_64.rpm



Gives access back to the systems

`yum downgrade` or `yum history undo` doesn't work since the package is missing.


The pain is getting these downgrades out to machines once you're locked out.

Comment 3 D.S. Ljungmark 2016-05-17 13:15:26 UTC
It's not enough to just downgrade one of the packages, both have to be up/down-graded in lockstep.

Comment 4 Fedora Update System 2016-05-31 09:52:29 UTC
pam_yubico-2.22-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6b1a26de10

Comment 5 Fedora Update System 2016-05-31 09:52:49 UTC
pam_yubico-2.22-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2e19bc36ef

Comment 6 Fedora Update System 2016-05-31 09:53:01 UTC
pam_yubico-2.22-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-447da92569

Comment 7 Fedora Update System 2016-05-31 09:53:13 UTC
pam_yubico-2.22-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ae2468303f

Comment 8 Fedora Update System 2016-05-31 20:50:35 UTC
pam_yubico-2.22-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6b1a26de10

Comment 9 Fedora Update System 2016-05-31 20:53:01 UTC
pam_yubico-2.22-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ae2468303f

Comment 10 Fedora Update System 2016-05-31 20:54:53 UTC
pam_yubico-2.22-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-447da92569

Comment 11 Fedora Update System 2016-06-01 08:29:23 UTC
pam_yubico-2.22-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2e19bc36ef

Comment 12 D.S. Ljungmark 2016-06-07 12:34:33 UTC
I still don't see a pushed update for this for Epel6. 

the ON_QA tag seems to be wrong.

Comment 13 Fedora Update System 2016-06-07 14:39:05 UTC
pam_yubico-2.22-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d121abcfb2

Comment 14 Fedora Update System 2016-06-07 14:39:20 UTC
pam_yubico-2.22-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6f1e3081d

Comment 15 Fedora Update System 2016-06-07 14:39:32 UTC
pam_yubico-2.22-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-06b2c329a7

Comment 16 Fedora Update System 2016-06-07 14:39:43 UTC
pam_yubico-2.22-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-dbf8e71b1a

Comment 17 Fedora Update System 2016-06-07 18:53:21 UTC
pam_yubico-2.22-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d121abcfb2

Comment 18 Fedora Update System 2016-06-08 02:23:30 UTC
pam_yubico-2.22-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-06b2c329a7

Comment 19 Fedora Update System 2016-06-08 02:23:51 UTC
pam_yubico-2.22-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6f1e3081d

Comment 20 Fedora Update System 2016-06-08 05:48:03 UTC
pam_yubico-2.22-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-dbf8e71b1a

Comment 21 Fedora Update System 2016-06-15 13:25:16 UTC
pam_yubico-2.23-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-86a7069446

Comment 22 Fedora Update System 2016-06-15 13:25:42 UTC
pam_yubico-2.23-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c20c1235f2

Comment 23 Fedora Update System 2016-06-15 13:25:58 UTC
pam_yubico-2.23-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a08da9fef1

Comment 24 Fedora Update System 2016-06-15 13:26:12 UTC
pam_yubico-2.23-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f44279a51

Comment 25 Fedora Update System 2016-06-15 13:26:28 UTC
pam_yubico-2.23-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b27797fa4

Comment 26 D.S. Ljungmark 2016-06-15 15:23:30 UTC
Bohdi doesn't let me comment, sadly.

pam_yubico-2.23-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-86a7069446


Solves the Segfault problem for us!

Comment 27 Fedora Update System 2016-06-15 16:55:47 UTC
pam_yubico-2.23-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f44279a51

Comment 28 Fedora Update System 2016-06-15 17:24:33 UTC
pam_yubico-2.23-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b27797fa4

Comment 29 Fedora Update System 2016-06-15 17:27:04 UTC
pam_yubico-2.23-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a08da9fef1

Comment 30 Fedora Update System 2016-06-16 15:18:36 UTC
pam_yubico-2.23-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c20c1235f2

Comment 31 Fedora Update System 2016-06-16 15:19:05 UTC
pam_yubico-2.23-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-86a7069446

Comment 32 Fedora Update System 2016-06-23 17:54:20 UTC
pam_yubico-2.23-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2016-06-24 01:50:57 UTC
pam_yubico-2.23-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2016-06-24 01:56:23 UTC
pam_yubico-2.23-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2016-07-02 16:19:25 UTC
pam_yubico-2.23-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 36 Fedora Update System 2016-07-02 23:49:37 UTC
pam_yubico-2.23-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.