Bug 1336782 - [RFE] [HA] Implement new, scalable, ops-friendly HA architecture with director integration for automatic deployment and updates
Summary: [RFE] [HA] Implement new, scalable, ops-friendly HA architecture with directo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 12:45 UTC by Rob Young
Modified: 2016-12-14 15:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:33:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Rob Young 2016-05-17 12:45:29 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Rob Young 2016-05-17 12:55:44 UTC
(In reply to Rob Young from comment #0)
> Description of problem:
Tracking RFE
Implement new, single, scalable, ops-friendly HA architecture with director integration for automatic deployment and updates.  The new HA architecture will be the only HA deployment option available via director beginning in OSP 10 (target) and will be based on the proposed Pacemaker Light architecture that is described in this doc:

https://docs.google.com/a/redhat.com/document/d/1nseqEWOPPgaXQFWnVNdxzLfrZG5EuJq_q-POzxf4mMk/edit?usp=sharing

A more detailed description, requirement of the new HA architecture is presented here (see slides for Pacemaker Light architecture)

https://docs.google.com/a/redhat.com/presentation/d/1ammrml9_fpxjrP2dSSiqUSvjxcl8wAiptBhtcH2LWPE/edit?usp=sharing



> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 3 Rob Young 2016-08-01 19:53:41 UTC
(In reply to Rob Young from comment #2)
> (In reply to Rob Young from comment #0)
> > Description of problem:
> Tracking RFE
> Implement new, single, scalable, ops-friendly HA architecture with director
> integration for automatic deployment and updates.  The new HA architecture
> will be the only HA deployment option available via director beginning in
> OSP 10 (target) and will be based on the proposed Pacemaker Light
> architecture that is described in this doc:
> 
> https://docs.google.com/a/redhat.com/document/d/
> 1nseqEWOPPgaXQFWnVNdxzLfrZG5EuJq_q-POzxf4mMk/edit?usp=sharing
> 
> A more detailed description, requirement of the new HA architecture is
> presented here (see slides for Pacemaker Light architecture)
> 
> https://docs.google.com/a/redhat.com/presentation/d/
> 1ammrml9_fpxjrP2dSSiqUSvjxcl8wAiptBhtcH2LWPE/edit?usp=sharing
> 
> 
> 
> > 
> > 
> > Version-Release number of selected component (if applicable):
> > 
> > 
> > How reproducible:
> > 
> > 
> > Steps to Reproduce:
> > 1.
> > 2.
> > 3.
> > 
> > Actual results:
> > 
> > 
> > Expected results:
> > 
> > 
> > Additional info:

The most current information on RHOSP High Availability Next Generation ("HA NG") is here:

https://docs.google.com/a/redhat.com/presentation/d/1K5qviRq38cqThuk5CjTnDYsZqlmO54gyomB0wjQ1P3g/edit?usp=sharing

Relevant information begins at slide 11 of this deck.

Comment 4 Michele Baldessari 2016-08-05 01:59:36 UTC
This has now landed in Newton

Comment 5 Fabio Massimo Di Nitto 2016-10-05 12:48:40 UTC
This has landed already. moving to MODIFIED.

Comment 6 Fabio Massimo Di Nitto 2016-10-08 14:22:59 UTC
This feature spans multiple packages. There isn´t a single FIV that fits them all, but it has landed in puddle and it´s been tested by QE.

Comment 9 Udi Shkalim 2016-10-17 10:15:53 UTC
Automation HA/E2E Passed on a clean deployment

Comment 14 errata-xmlrpc 2016-12-14 15:33:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.