Bug 133679 - (nvidia-composite) xorg 6.8.1 is unable to load composite extension, though I have enable it in config.
xorg 6.8.1 is unable to load composite extension, though I have enable it in ...
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2004-09-26 03:11 EDT by Knut J BJuland
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-27 22:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg config file (1.87 KB, text/plain)
2004-09-26 03:12 EDT, Knut J BJuland
no flags Details
xorg log (79.18 KB, text/plain)
2004-09-26 03:13 EDT, Knut J BJuland
no flags Details
xdpyinfo output (5.94 KB, text/plain)
2004-09-26 03:14 EDT, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2004-09-26 03:11:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
xorg 6.8.1 is unable to load composite extension, though I have enable
it in config. xpdyinfo report composite extension to be missing while
/var/log/Xorg.log reports is to have loaded.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.enable composite in xorg.conf

Actual Results:   xcompmgr reports No composite extension

Expected Results:   xcompmgr should start

Additional info:
Comment 1 Knut J BJuland 2004-09-26 03:12:19 EDT
Created attachment 104327 [details]
xorg config file
Comment 2 Knut J BJuland 2004-09-26 03:13:36 EDT
Created attachment 104328 [details]
xorg log
Comment 3 Knut J BJuland 2004-09-26 03:14:53 EDT
Created attachment 104329 [details]
 xdpyinfo output
Comment 5 Pekka Pietikäinen 2004-09-27 11:47:30 EDT
Works for me, NVIDIA 6111 driver, xorg-x11-6.8.1-3, 
xcompmgr, transset and everything...

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce FX (generic)"
        Option "RenderAccel" "true"

Section "Extensions"
        Option "Composite" "Enable"
Comment 6 Dwaine Garden 2004-09-27 21:29:28 EDT
Works fine with my computer.  I'm using the vendor provided nvidia
binary driver.
Comment 7 Dwaine Garden 2004-09-27 21:31:47 EDT
Here is my output from my own xorg.log file....

(II) NVIDIA(0): Setting mode "1600x1200"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
Comment 8 Mike A. Harris 2004-09-27 22:16:28 EDT
Thanks for the report.  The COMPOSITE extension will be supported
in a future OS release, however at this time it is only an
experimental X server extension.  In order to use COMPOSITE, you
must manually configure it by hand as you've done in your config
file, and you must install a compositing manager such as 'xcompmgr'
which is not included with Fedora Core.  You can get 'xcompmgr'
from freedesktop.org if you don't already have it or a window
manager that has a built in compositing manager.

Several people have reported to have gotten COMPOSITE to work,
so it is possible that your X server may be misconfigured or that
the vendor driver you are using doesn't support your combination
of OS/X server/kernel/hardware.

If you experience any problems with the COMPOSITE extension, please
report them directly to X.Org, so that any problems that arise
can be investigated by X.Org developers and fixed before COMPOSITE
becomes an officially supported X server extension.

    http://bugs.freedesktop.org in the 'xorg' component

Also, if you are using unsupported proprietary video drivers and
having any difficulties with them, you can try any of the following
support mechanisms to try and get assistance:

- The hardware vendor's website.  Be sure that the vendor claims
  that their drivers officially support the OS release, X server
  release and specific functionality you are wanting to use.  In
  particular it may take hardware vendors several months before
  they have added support for new X server functionality into their
  drivers and officially support it on the OS release you are using.

- The hardware vendor's public help forums (if any).  Many hardware
  vendors (such as Nvidia) have public web support forums.

- The X.Org, freedesktop.org and/or XFree86 mailing lists.

- The Red Hat public mailing lists.

Setting bug status to "NOTABUG".  If you continue to have
difficulties, you may wish to use one of the above suggested
support forums for assistance.

Comment 9 Andrew Farris 2004-09-28 15:35:04 EDT
Success report:
Composite is working for me very nicely using the nVIDIA 6111 driver,
FC3t2 with these package versions:

I have built the kernel module independently but have installed the
driver with the Livna.org package.  Composition works in both Gnome
(metacity) and XFCE4 using xcompmgr from freedesktop.org cvs
(26sept2004).  I use the command line:
xcompmgr -c -C -f -F -o 1.0 -I 0.08 &

Some windows have slight issues but the majority work correctly, even
flash objects drawn in Firefox are composited with no major slowdowns.
 Firefox was reported elsewhere to crash X when composited.
Comment 10 Lars G 2004-09-29 11:59:28 EDT
plays nice here too with latest nvidia & rawhide.

openGL windows don't render correctly (overlay issues, x crashing
sometimes..., but removing the composite config lines from xorg.conf makes
openGL work fine again...)
and sometimes windows don't get updated and are tearing a bit,
but nevertheless its working great for a *preview* ! :)


ps. here is an mail from nvidia about this topic i got

Re: new XOrg with composite extensions and opengl problem

xxx xxx <xxx@nvidia.com>

Lars <terraformers@gmx.net>


2004-09-17 03:59

Greetings, Lars.  Thank you for your email.  We are investigating
adding GLX support for Damage/Composite in a future release, but
I do not have an ETA at this time.

Thanks for your interest,
- xxx xxx

On Fri, 17 Sep 2004, Lars wrote:

> hello nvidia team!
> i have a problem to get openGL windows running with the new Xorg X11
> with composite extension enabled & xcommgr.
> im using the 6111 driver release with renderaccel on and everytime i
start an 
> ogl app the screen is messed up with wrong overlays or something
> etc...)
> when using wings3d modeler the xcommgr segfaults.
> and running xcommgr and doing a "glxinfo" X11 restarts.
> running "glxgears" draws the app right but when i put it in the
background of 
> another window the ogl display stays on top (overlay).
> would be great if you can fix this in a future release, because the new 
> composite extension looks soooo damn sweet with hardware softshadows
> blend-in effects.  think osx ;)
> everything else i tried with this extension enabled, worked speedy &
like a 
> charm.
> cheers
> lars
Comment 11 Lars G 2004-09-29 12:10:26 EDT
here is how-i-did-it

in /etc/X11/xorg.conf i had to add:

Section "Extensions"
 Option "Composite" "Enable"

and in the nvidia device section of the same file:

Option       "RenderAccel" "on"

after restarting X one needs the xcompmgr
get it with:
cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/xapps login
cvs -d :pserver:anoncvs@pdx.freedesktop.org:/cvs/xapps co xcompmgr

make it, and start it with "xcompmgr -c -f -F" when X is running.

Comment 12 Kil In Linux 2005-01-08 04:57:49 EST

I add option "GLXWithComposite" in NVidia's driver in xorg.conf and
now, GLX AND Composite run fine.

Bugs with GLX Windows in move windows and GLX was always in front but
it's works...
Comment 13 No name for internet 2005-05-11 19:15:00 EDT
This bug it's the same with ATI drivers. 
When Composite is ''on'' the ATI Open glx is don't load. 
But mesa open gl is load.  also the 3D hardwear don't work.

the driver ati used is : fglrx_6_8_0-8.12.10-1.i386.rpm
the kernel is the last kernel or/and 2.6.10-xx 770.

Please ! don't forget Ati !!!
(sorry for my english!)
Comment 14 Mike A. Harris 2005-05-11 22:46:41 EDT
ATI isn't reading this bug report most likely.  You'll need to contact
ATI directly if you want them to add this support to their drivers.

We do not even ship ATI's fglrx driver, so your request in our bugzilla,
definitely isn't going to be seen by anyone who can make it happen.

Visit: http://www.ati.com go to the drivers section, and somewhere in there
is a link where you can provide ATI feedback.  I don't remember the exact
URL, but it shouldn't be hard to find, as long as they still have the
web form there.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.