Bug 1336800 - Race condition while expanding tilda may cause bash to skip updating ~/.bash_history
Summary: Race condition while expanding tilda may cause bash to skip updating ~/.bash_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 24
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Siteshwar Vashisht
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 13:15 UTC by Siteshwar Vashisht
Modified: 2016-05-23 20:05 UTC (History)
2 users (show)

Fixed In Version: bash-4.3.42-5.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 20:05:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Siteshwar Vashisht 2016-05-17 13:15:47 UTC
Description of problem:
If SIGHUP is received while expanding tilda, bash may skip updating ~/.bash_history due to a race condition.

Version-Release number of selected component (if applicable):
bash-4.3.42-4

How reproducible:
Very rarely

Actual results:
bash does not update ~/.bash_history

Expected results:
bash should update ~/.bash_history

Additional info:

Upstream bug report: http://lists.gnu.org/archive/html/bug-bash/2016-04/msg00106.html

Patch: http://lists.gnu.org/archive/html/bug-bash/2016-04/msg00136.html

Comment 2 Fedora Update System 2016-05-17 16:50:13 UTC
bash-4.3.42-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d4344c4a2

Comment 3 Fedora Update System 2016-05-21 01:35:50 UTC
bash-4.3.42-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d4344c4a2

Comment 4 Fedora Update System 2016-05-23 20:05:10 UTC
bash-4.3.42-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.