Bug 133681 - gnome-vfs2 allocates all memory and thrashes the box to death
gnome-vfs2 allocates all memory and thrashes the box to death
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-26 03:49 EDT by Nicholas Miell
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 11:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2004-09-26 03:49:31 EDT
Due to a bug in libegg
(http://bugzilla.gnome.org/show_bug.cgi?id=153759), gnome-vfs2 will
frequently allocate multi-gigabyte chunks of RAM and thrash the box to
death.

I've had the panel, nautilus, and firefox all trigger the problem.

Because of sizeof(void*) verses sizeof(int) issues, I think this will
only trigger on 64-bit architectures (and probably only little-endian
ones, at that).
Comment 1 Jonathan Blandford 2004-09-28 23:02:01 EDT
This was fixed upstream and in our packages, right ray?
Comment 2 Nicholas Miell 2004-09-28 23:49:09 EDT
Note that upstream was fixed twice
Comment 3 Ray Strode [halfline] 2004-09-29 00:23:27 EDT
Should be fixed in tomorrow's rawhide.
Comment 4 Nicholas Miell 2004-09-30 17:09:27 EDT
desktop-file-utils-0.8.tar.gz has it's own unfixed copy of
eggdesktopentries.c
Comment 5 Ray Strode [halfline] 2004-10-01 11:41:01 EDT
it was fixed in desktop-file-utils-0.9
Comment 6 Nicholas Miell 2004-10-02 01:42:27 EDT
The gnome-vfs2 package still embeds desktop-file-utils 0.8, but I
guess that doesn't matter because the gnome-vfs2 package only uses
libmenu.so from desktop-file-utils, and that doesn't use
eggdesktopentries.c

Note You need to log in before you can comment on or make changes to this bug.