Bug 1336810 - Calligra Words crashed when I opened a template.
Summary: Calligra Words crashed when I opened a template.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calligra
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-05-17 13:36 UTC by pavel raur
Modified: 2016-05-23 20:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 20:05:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 345240 None None None 2016-05-17 14:07:11 UTC

Description pavel raur 2016-05-17 13:36:13 UTC
Description of problem:
On the system instaled from kde live cd. I started calligra words and used default template. Than calliga crashed.

$ calligrawords
Legacy integer arithmetics implementation 
KCrash: Application 'calligrawords' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
KCrash: Connect sock_file=/home/ja/.kde/socket-dhcp-28-111.brq.redhat.com/kdeinit4__0

[1]+  Pozastavena             calligrawords


Version-Release number of selected component (if applicable):
calligra-words-2.9.11-4.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Start callibra words
2.Try to use a template

Actual results:
Calligra crashes

Expected results:
Creating new document using selected template

Additional info:

Comment 1 Fedora Blocker Bugs Application 2016-05-17 13:39:29 UTC
Proposed as a Blocker for 24-final by Fedora user me2 using the blocker tracking app because:

 I propose this bug as final blocker. It clearly violates the final criterion:
"Default application functionality

All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
Calligra is installed by default on KDE from liveCD.

Comment 2 Rex Dieter 2016-05-17 14:01:38 UTC
Found an upstream report already, that seems to match the symptoms and backtrace,
https://bugs.kde.org/show_bug.cgi?id=363071

Comment 3 Rex Dieter 2016-05-17 14:05:48 UTC
The upstream reports seem to point to this being a soprano issue, where it cannot find any backend plugins.

Unfortunately, our soprano packaging includes at least one default backend: redland.  

Already had to patch soprano for some gcc6'isms, I suspect something else isn't working right.

Comment 4 Rex Dieter 2016-05-17 14:27:27 UTC
Simply rebuilding soprano seems to fix it for me (old gcc/toolchain bug?) I'll whip up some new soprano builds for testing.

Comment 5 Fedora Update System 2016-05-17 14:46:54 UTC
soprano-2.9.4-14.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6492262192

Comment 6 Fedora Update System 2016-05-17 21:59:52 UTC
soprano-2.9.4-14.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6492262192

Comment 7 Viorel Tabara 2016-05-23 03:44:51 UTC
Tested OK and added comment in Bodhi.

Comment 8 Geoffrey Marr 2016-05-23 18:05:03 UTC
Discussed during the 2016-05-23 blocker review meeting: [1]

This has been accepted as a final blocker bug as it violates the following criteria: [2]

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-05-23/f24-blocker-review.2016-05-23-16.00.txt

[2] https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#Default_application_functionality

Comment 9 Fedora Update System 2016-05-23 20:05:16 UTC
soprano-2.9.4-14.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.