Bug 133684 - unable to open an initial console - ppc only
unable to open an initial console - ppc only
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks: fedora-ppc FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-26 04:57 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 09:34:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shot of the breakage (250.21 KB, image/jpeg)
2004-10-09 20:34 EDT, Colin Charles
no flags Details

  None (edit)
Description Colin Charles 2004-09-26 04:57:16 EDT
Description of problem: "unable to open an initial console" is
displayed, then a few SELinux context messages, then it just hangs
there, and booting does not go further. This is similar to Bug #132862
however it _only_ affects PowerPC with the 2509 tree - I did an x86
install, and that went perfectly


Version-Release number of selected component (if applicable):
udev-032-2.ppc.rpm

How reproducible:
100%

Steps to Reproduce:
1. Perform fresh install on iMac DV SE (powerpc)
2. Reboot
  
Actual results:
See error message as in Bug #132862, and the booting hangs there

Expected results:
/sbin/start_udev runs, device nodes get created, and I can boot again

Additional info:
When I booted into rescue mode, chrooted to /mnt/sysimage, executing
/sbin/start_udev meant things worked well for me (I got all the
devices in /dev that I needed). This is how I ran yabootconfig, and so on.

But for some reason, during a normal bootup, its not being picked up
in a timely fashion. Maybe there's some rc scripts that need changing,
I haven't poked at this issue yet.

Also, comment #5 in bug #132862 was tried, but that wasn't the cause
of the problem. This wasn't an upgrade to begin with, but a fresh
Everything install
Comment 1 Harald Hoyer 2004-09-27 04:09:04 EDT
which kernel version?
Comment 2 Colin Charles 2004-09-28 04:27:19 EDT
/kernel-2.6.8-1.541.ppc.rpm

Latest as of Rawhide then
Comment 5 David Woodhouse 2004-10-08 13:39:10 EDT
Reproduced with today's rawhide on peach.cambridge.redhat.com
Comment 6 Colin Charles 2004-10-09 20:33:08 EDT
Can reproduce with the .603 kernel, on a fresh rawhide latest install,
from the 0910 tree.

Trying dwmw2's suggestion on irc to mknod /mnt/sysimage/dev/console c
5 1 makes it boot further (yay!), but more errors are thrown, as per
the graphic attachment
Comment 7 Colin Charles 2004-10-09 20:34:57 EDT
Created attachment 104977 [details]
shot of the breakage

after adding /dev/console manually. Otherwise, there is just the error that
/dev/console isn't found as per the bug report, and it doesn't boot further
Comment 8 David Woodhouse 2004-10-10 06:38:57 EDT
Disable the bloody stupid mount-by-label. Use device names in your
fstab and on your kernel command line.

Mount by label is never going to help you much on a desktop-class
system. It's only really appropriate on big servers where you're
likely to be moving discs around. On a desktop-class system it'll only
offer one more likely point of failure, like this.
Comment 9 Harald Hoyer 2004-10-11 04:45:26 EDT
this all looks like /dev is not a mounted tmpfs, which should happen
in initramfs, produced by mkinitrd.
Comment 10 Ralf Ertzinger 2004-10-26 08:09:01 EDT
I've gotten this, too. The reason (and thus the fix) was that
yaboot.conf did not contain an "initrd=" line. Adding that makes it
work (rawhide as of 24 Oct. 2004)
Comment 11 Colin Charles 2004-10-28 13:50:08 EDT
Ralf, in comment #10, fresh install on the 28th Oct on iMac DV SE,
yaboot.conf had an initrd line (i.e. the default one now has it too -
I remember adding it before), and it still broke !

Though I should add, /dev/console is being created. When logged into
"linux rescue" mode, I can see quite the few entries in
/mnt/sysimage/dev (~195 or so). So why it still complains, I'm wondering

SELinux is enabled, just in case that makes a difference (selinux=0
when booting didn't seem to)
Comment 12 Colin Charles 2004-11-06 04:15:09 EST
Rawhide latest (okay, its just FC3), and the install went fine, got
the usualy sillyness for unable to find inital console, even with the
initrd in /etc/yaboot.conf. Tried with the sysmap= option too

Following Harald's udev page to actually start without an initrd, I
did that, rebooted with selinux=0, and the mac's happy

So for some reason, yaboot isn't recognising the initrd properly ? I
guess its becoming less of a udev "bug", and might only seem prevalent
in this iMac DV SE (i'll fiddle w/it on an iBook later)
Comment 13 Colin Charles 2005-01-11 09:34:05 EST
Okay, I opened this bug, and its fixed in the testing tree that we
released as FC-3 that sits on fedoraproject.org so I'm going to close
this as currentrelease as I don't think it bothers anyone, any longer.

yaboot boots fine when an intird= is specified.

Note You need to log in before you can comment on or make changes to this bug.