Bug 133688 - /dev/mapper/control is not created by udev
/dev/mapper/control is not created by udev
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3SELinux
  Show dependency treegraph
 
Reported: 2004-09-26 08:52 EDT by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: udev-032-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 05:40:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-09-26 08:52:46 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
echo "mkdmnod" | /sbin/nash --quiet >/dev/null 2>&1 
 
Currently the above line in /etc/rc.d/rc.sysinit is used to 
create /dev/mapper/control because udev does not do so.  I believe 
this is wrong.  Only udev should be creating device nodes. 
 
Please make udev create /dev/mapper/control if the dm_mod module is 
loaded so that rc.sysinit does not need to do it. 
 
NB  This change is needed to allow improvements to the SE Linux 
policy. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
Comment out the mkdmnod line from rc.sysinit and observe that there 
is no /dev/mapper/control. 
 
Additional info:
Comment 1 Alasdair Kergon 2004-09-29 18:18:13 EDT
Medium-term, I'll aim to get libdevmapper to create it transparently.

Note You need to log in before you can comment on or make changes to this bug.