Bug 1336928 - unable to view compliance reports
Summary: unable to view compliance reports
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 20:23 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:37 UTC (History)
3 users (show)

Fixed In Version: rubygem-foreman_openscap-0.5.3.8-1,rubygem-foreman_openscap-0.5.3.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:20:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
compliance reports page now is visible (65.30 KB, image/png)
2016-05-26 12:28 UTC, Kedar Bidarkar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 14919 0 Normal Closed Recent changes broke Arf report dashboard widget 2020-09-01 22:09:16 UTC
Foreman Issue Tracker 15075 0 Normal Closed unable to view compliance reports 2020-09-01 22:09:16 UTC

Description Kedar Bidarkar 2016-05-17 20:23:40 UTC
Description of problem:

Currently we are unable to view the OSCAP compliance reports and we see this message on the UI.

Oops, we're sorry but something went wrong undefined method `authorized?' for #<#<Class:0x00000008fdbe90>:0x007f59ad4ad158>


2016-05-17 16:17:34 [app] [I] Started GET "/compliance/arf_reports" for 10.10.54.176 at 2016-05-17 16:17:34 -0400
2016-05-17 16:17:34 [app] [I] Processing by ArfReportsController#index as HTML
2016-05-17 16:17:34 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.5.3.5/app/views/arf_reports/_list.html.erb (324.1ms)
2016-05-17 16:17:34 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.5.3.5/app/views/arf_reports/index.html.erb within layouts/application (336.4ms)
2016-05-17 16:17:34 [app] [W] Action failed
 | NoMethodError: undefined method `authorized?' for #<#<Class:0x00000008fdbe90>:0x00000008fd9fa0>
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.5.3.5/app/views/arf_reports/_list.html.erb:16:in `block in _3b3b8c00374b64565d725f41c0883c8f'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/delegation.rb:46:in `each'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/delegation.rb:46:in `each'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.5.3.5/app/views/arf_reports/_list.html.erb:13:in `_3b3b8c00374b64565d725f41c0883c8f'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/template.rb:145:in `block in render'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/notifications.rb:161:in `instrument'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/template.rb:339:in `instrument'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/template.rb:143:in `render'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/deface-1.0.2/lib/deface/action_view_extensions.rb:41:in `render'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/renderer/partial_renderer.rb:306:in `render_partial'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/renderer/partial_renderer.rb:279:in `block in render'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionview-4.1.5/lib/action_view/renderer/abstract_renderer.rb:38:in `block in instrument'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/notifications.rb:159:in `block in instrument'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/notifications.rb:159:in `instrument'


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. After running "foreman_scap_client 1"
2. Navigate to the compliance report page to view the oscap reports, to see the error.
3.

Actual results:
Unable to view compliance reports.

Expected results:
Should be able to see compliance reports.

Additional info:

Comment 3 Shlomi Zadok 2016-05-18 06:37:48 UTC
Created redmine issue http://projects.theforeman.org/issues/15075 from this bug

Comment 4 Shlomi Zadok 2016-05-18 06:39:32 UTC
https://github.com/theforeman/foreman_openscap/pull/164 fixed the issue

Comment 6 Kedar Bidarkar 2016-05-26 12:26:43 UTC
We can now view the OSCAP compliance reports page.

VERIFIED with sat62-snap(GA)13.1

Comment 7 Kedar Bidarkar 2016-05-26 12:28:37 UTC
Created attachment 1161972 [details]
compliance reports page now is visible

Comment 8 Bryan Kearney 2016-07-27 11:20:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.