Bug 1336931 - rgw: multipart object corruption when uploading the same part concurrently
Summary: rgw: multipart object corruption when uploading the same part concurrently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 1.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Orit Wasserman
QA Contact: rakesh
URL:
Whiteboard:
Depends On:
Blocks: 1336933 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-17 20:28 UTC by Yehuda Sadeh
Modified: 2017-07-30 15:50 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1336933 (view as bug list)
Environment:
Last Closed: 2016-08-23 19:38:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 15886 0 None None None 2016-05-17 20:28:32 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Yehuda Sadeh 2016-05-17 20:28:33 UTC
Description of problem:

There's a certain scenario where a user can create corrupted multipart objects, by concurrent upload of the same part.


Version-Release number of selected component (if applicable):
1.3.x, 2.0

How reproducible:
always -- if done correctly


Steps to Reproduce:
1. initiate multipart upload
2. start uploading part (first upload)
3. start uploading the same part (second upload)
4. finish uploading the part (second upload)
5. finish uploading the part (first upload)
6. complete multipart upload
7. read object

Actual results:
object is corrupted

Expected results:
object should not be corrupted


Additional info:

Comment 6 Ken Dreyer (Red Hat) 2016-06-14 16:21:31 UTC
We will take this change in as part of the rebase to ceph 10.2.2.

Comment 8 rakesh 2016-08-04 13:46:14 UTC
Ran the automated suite from here https://github.com/ceph/s3-tests
the test related to this is : https://github.com/ceph/s3-tests/blob/master/s3tests/functional/test_s3.py#L5907

the test passed and hence marking this test case as verified.

Comment 10 errata-xmlrpc 2016-08-23 19:38:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.