Bug 1336953 - Ansible : Ansible Tower Quadicon does not display details
Summary: Ansible : Ansible Tower Quadicon does not display details
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.6.0
Assignee: Milan Zázrivec
QA Contact: Pavol Kotvan
URL:
Whiteboard: ui:tower
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-17 21:29 UTC by Shveta
Modified: 2018-03-14 09:38 UTC (History)
7 users (show)

Fixed In Version: 5.6.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 16:03:27 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
no details (82.30 KB, image/png)
2016-05-17 21:29 UTC, Shveta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Shveta 2016-05-17 21:29:08 UTC
Created attachment 1158541 [details]
no details

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add an ansible provider under configuration manager
2. Switch to Grid View
3. Click on Quadicon , Nothing happens.
4. If it is List View , click the list item , it displays Inventory .

Actual results:


Expected results:


Additional info:
5.6.0.6-beta2.5.20160511140943_ff75fb2

Comment 3 Shveta 2016-05-17 23:00:54 UTC
Yes the details are displayed in List View.

Comment 5 Milan Zázrivec 2016-05-20 08:43:07 UTC
https://github.com/ManageIQ/manageiq/pull/8841

Comment 6 CFME Bot 2016-05-20 14:40:55 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/946f8e7af57b9c5a20d12e3089acede50e63e248

commit 946f8e7af57b9c5a20d12e3089acede50e63e248
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Fri May 20 10:39:02 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Fri May 20 10:39:02 2016 +0200

    Fix creation of url ids for GTL view under config. providers
    
    list_row_id(row) is supposed to return id for a given object for
    any of the GTL views. Returning just prefix for the given model
    would lead to incorrect url being construted and a silent
    error when clicking on the constructed url.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1336953

 app/controllers/provider_foreman_controller.rb | 2 --
 1 file changed, 2 deletions(-)

Comment 7 Shveta 2016-05-26 17:43:03 UTC
Fixed.
Verified in 

5.6.0.8-rc1.20160524155303_f2a5a50

Comment 9 errata-xmlrpc 2016-06-29 16:03:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.