Bug 1337211 - Missing information in cluster configuration
Summary: Missing information in cluster configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-18 13:50 UTC by Lubos Trilety
Modified: 2016-08-23 19:50 UTC (History)
5 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
current cluster configuration (273.09 KB, image/png)
2016-05-19 18:48 UTC, Lubos Trilety
no flags Details
cluster configuration design (350.04 KB, image/png)
2016-05-19 19:03 UTC, Lubos Trilety
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-05-18 13:50:29 UTC
Description of problem:
Via design some fields are missing on cluster configuration tab.
There's no:
Red Hat Ceph Storage
Provider Version
Remote Execution Agent
SELinux Mode
Monitors required for Quorum
Minimum Replicas
Polling Interval

Except polling interval (monitoring interval) all of them are missing in API too.

Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.15-1.el7scon.x86_64
rhscon-core-0.0.18-1.el7scon.x86_64
rhscon-ui-0.0.31-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Look for configuration information for some cluster on UI and using API too
2.
3.

Actual results:
Some information is missing

Expected results:
All relevant information is available

Additional info:

Comment 1 Nishanth Thomas 2016-05-19 06:57:22 UTC
More info and screen shot required

Comment 2 Lubos Trilety 2016-05-19 18:48:41 UTC
Created attachment 1159603 [details]
current cluster configuration

Comment 3 Lubos Trilety 2016-05-19 19:03:38 UTC
Created attachment 1159609 [details]
cluster configuration design

Comment 4 Lubos Trilety 2016-05-19 19:08:27 UTC
'current cluster configuration' attachment is how it looks as of now, 'design cluster configuration' is what the design said. The missing fields are marked by red strokes in 'design cluster configuration'.

Comment 5 Nishanth Thomas 2016-05-24 07:10:17 UTC
Polling interval can be added. 

Rest of the things(below) doesn't make much of sense at cluster confiug level:

Red Hat Ceph Storage
Provider Version
Remote Execution Agent
SELinux Mode

Is there any specific config in ceph cluster as below?

Monitors required for Quorum
Minimum Replicas 

Ju, Matt, Please provide required info

Comment 6 Nishanth Thomas 2016-06-03 12:57:13 UTC
As per the discussion Polling interval, Monitors required for Quorum and Minimum Replicas to be populated

Comment 7 Ju Lim 2016-06-03 14:18:50 UTC
Based on RHS Console Bug Scrub Activity today, it was decided that we can defer showing the following for 1.0 as there is only a single version of Ceph supported, a single provider, etc. for 1.0:

* Red Hat Ceph Storage
* Provider Version
* Remote Execution Agent
* SELinux Mode

Note: For SELinux, it's only read-only in 1.0, and there is no ability to set it as of yet hence will not be needed for 1.0.

Comment 8 gowtham 2016-06-21 06:17:28 UTC
Minimum Replicas and Polling Interval are added in api(/api/v1/clusters/{cluster-id}/config)
    
    Minimum Replicas - osd_pool_default_min_size
    Polling Interval - monitoringinterval

Comment 9 Nishanth Thomas 2016-06-21 09:53:29 UTC
Monitors required for Quorum is not available through calamari API(https://<IP>:8002/api/v2/cluster/<cluster-id>/config). So this needs to be de scoped from 2.0

Comment 10 Nishanth Thomas 2016-06-21 09:54:12 UTC
Ju, ack please

Comment 11 Nishanth Thomas 2016-06-21 13:29:18 UTC
No change required in core , moving to UI

Comment 12 Ju Lim 2016-06-21 18:46:16 UTC
As Calamari API does not provide APO support for "Monitors required for Quorum" it is fine to leave this out of 1.0.  It's a nice-to-have.  Can deferred to 2.0.

Comment 15 Lubos Trilety 2016-07-20 12:17:14 UTC
Tested on:
rhscon-ui-0.0.48-1.el7scon.noarch
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64

Minimum Replicas and Polling Interval added to the cluster configuration on UI and on API too.

Comment 17 errata-xmlrpc 2016-08-23 19:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.