Bug 1337226 - resync'ing some repos taking a very long time
Summary: resync'ing some repos taking a very long time
Keywords:
Status: CLOSED DUPLICATE of bug 1315006
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker rhci-common-installer
TreeView+ depends on / blocked
 
Reported: 2016-05-18 14:29 UTC by Jason Montleon
Modified: 2021-04-06 17:57 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-13 20:44:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Foreman Debug (538.70 KB, application/x-xz)
2016-05-18 14:29 UTC, Jason Montleon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 1949 0 High CLOSED - CURRENTRELEASE re-publish takes longer than expected 2016-07-18 19:30:54 UTC

Description Jason Montleon 2016-05-18 14:29:14 UTC
Created attachment 1158873 [details]
Foreman Debug

Description of problem:
Resync'ing Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server x86_64 7Server and Red Hat Enterprise Linux 7 Server - Extras RPMs x86_64 repos is taking an extreme amount of time.

Version-Release number of selected component (if applicable):
pulp-admin-client-2.8.1.3-1.el7sat.noarch
pulp-client-1.0-1.noarch
pulp-docker-plugins-2.0.0.2-1.el7sat.noarch
pulp-katello-1.0-3.el7sat.noarch
pulp-puppet-plugins-2.8.1-2.el7sat.noarch
pulp-puppet-tools-2.8.1-2.el7sat.noarch
pulp-rpm-plugins-2.8.1.3-1.el7sat.noarch
pulp-selinux-2.8.1.3-1.el7sat.noarch
pulp-server-2.8.1.3-1.el7sat.noarch
python-pulp-bindings-2.8.1.3-1.el7sat.noarch
python-pulp-client-lib-2.8.1.3-1.el7sat.noarch
python-pulp-common-2.8.1.3-1.el7sat.noarch
python-pulp-docker-common-2.0.0.2-1.el7sat.noarch
python-pulp-oid_validation-2.8.1.3-1.el7sat.noarch
python-pulp-puppet-common-2.8.1-2.el7sat.noarch
python-pulp-repoauth-2.8.1.3-1.el7sat.noarch
python-pulp-rpm-common-2.8.1.3-1.el7sat.noarch
python-pulp-streamer-2.8.1.3-1.el7sat.noarch
rubygem-smart_proxy_pulp-1.2.0-1.el7sat.noarch
foreman-1.11.0.17-1.el7sat.noarch
tfm-rubygem-katello-3.0.0.24-1.el7sat.noarch

How reproducible:
Seems to be always. Multiple people on the QCI Team have noticed this.

Steps to Reproduce:
1. Install Satellite 6.2 Beta
2. Sync:
Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server x86_64 7Server
Red Hat Enterprise Linux 7 Server - Extras RPMs x86_64
3. Re-sync the repos

Actual results:
Re-sync'ing these repos takes between 30 minutes and one hour.

Expected results:
re-sync'ing with no changes should be fairly quick

Additional info:
The initial syncs for these repos were 6 and 18 minutes.

Other repos resync very quickly. These are the only two we have found thus far that behave this way.

Comment 2 Michael Hrivnak 2016-05-23 18:02:11 UTC
Using upstream pulp 2.8.3, I saw these times for the initial sync of the "extras" repo:

150.5s sync
17.7s publish

Then the second sync and publish took this long:

5.1s sync
15.2s publish

Comment 3 Michael Hrivnak 2016-05-26 16:31:39 UTC
We did narrow down that it is the publish task that is taking so long, not the sync. It's difficult to distinguish as a user, since they both happen as part of one operation.

Comment 4 Michael Hrivnak 2016-06-01 13:06:52 UTC
This is very likely a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1315006

Comment 5 Brad Buckingham 2016-06-03 15:32:24 UTC
Michael, can/should this be closed as a duplicate?

Comment 6 Michael Hrivnak 2016-06-13 17:45:28 UTC
I suggest closing 1315006 and keeping this one open, just because I like the quality of debugging content on this one a little more. :) This one is also already aligned with our corresponding upstream pulp bug.

Comment 7 Brad Buckingham 2016-06-13 19:21:10 UTC
*** Bug 1315006 has been marked as a duplicate of this bug. ***

Comment 8 Brad Buckingham 2016-06-13 20:44:42 UTC
Since bug 1315006 was fully triaged, we are closing this one.

*** This bug has been marked as a duplicate of bug 1315006 ***

Comment 9 pulp-infra@redhat.com 2016-06-20 14:30:25 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2016-06-20 14:30:27 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-06-24 17:17:26 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 12 pulp-infra@redhat.com 2016-06-24 20:30:28 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 13 pulp-infra@redhat.com 2016-07-04 02:30:27 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 14 pulp-infra@redhat.com 2016-07-18 19:30:55 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.


Note You need to log in before you can comment on or make changes to this bug.