Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337238 - subscription-manager-plugin-container-1.15.9-15.el7.x86_64 (rhel-optional) Requires: subscription-manager = 1.15.9-15.el7 Installed: subscription-manager-1.17.6-1.el7.x86_64 (@rhel-released)
Summary: subscription-manager-plugin-container-1.15.9-15.el7.x86_64 (rhel-optional) Re...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 14:57 UTC by Jan Stavel
Modified: 2016-05-24 13:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-24 13:22:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Stavel 2016-05-18 14:57:44 UTC
Description of problem:


Version-Release number of selected component (if applicable):

   Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
   ----------------------------     ----------------------------
   arch                             x86_64
   kernel version                   3.10.0-327.el7.x86_64
   ----------------------------     ----------------------------
   server type                      This system is currently not registered.
   subscription management server   Unknown
   subscription management rules    Unknown
   subscription-manager             1.17.6-1.el7
   python-rhsm                      1.17.2-1.el7
   ----------------------------     ----------------------------
   Product                          69.pem
   ----------------------------     ----------------------------
   Entitlement                      ----------------------------  

How reproducible:


Steps to Reproduce:

     yum -y install subscription-manager-plugin-container --nogpgcheck


Actual results:

The package is not installable.

Comment 1 vritant 2016-05-23 20:34:29 UTC
Jan,
how did you install subscription manager?
What repositories are you accessing?

Comment 3 Jan Stavel 2016-05-24 12:39:45 UTC
Hi Vritant
I have propably made a confusion using repos from various compose tree.

I am going to reproduce this issue following a John's sudgestion and I will confirm or reject this issue.

Regards,
Jan

Comment 4 Jan Stavel 2016-05-24 12:55:00 UTC
Hi Vritant,
once I have enabled repos from last night build including optional
the bug disappears.

This bug was caused by mixing repos from different composes:
- I installed a system from nightly build compose
- I subscribed a system (ie. released repos came to play including optional)
- since plugin comes from optional repo a conflict between released optional repo and installed main nightly build repo was risen.

The same is with a bug https://bugzilla.redhat.com/show_bug.cgi?id=1337232


Note You need to log in before you can comment on or make changes to this bug.