Bug 1337298 - Non-zero chargeback costs when CPU usage is zero
Summary: Non-zero chargeback costs when CPU usage is zero
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.0
Assignee: tledesma
QA Contact: Nandini Chandra
URL:
Whiteboard: report:chargeback
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 18:29 UTC by Nandini Chandra
Modified: 2017-10-10 18:26 UTC (History)
8 users (show)

Fixed In Version: 5.6.0.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 16:04:09 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Chargeback report (37.92 KB, application/pdf)
2016-05-18 18:29 UTC, Nandini Chandra
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Nandini Chandra 2016-05-18 18:29:33 UTC
Created attachment 1159026 [details]
Chargeback report

Description of problem:
-----------------------
When resource usage is zero, a non-zero cost is being reported in Chargeback reports.According to the Chargeback rates I've defined, the cost should be zero.

Range(start-finish)|Rate(fixed, variable)
--------------------------------
0.0 - 700.0        |0, 0.04
700 - 3500         |0, 0.03
3500- 8500         |0, 0.02
8500-Infinity      |0, 0.01  

In the attached chargeback report, CPU used for the 'cu-9-5' VM on 05/14/2016
is 0 MHz.But, the cost reported is $1.04.

Also, see bug 1337278 .


Version-Release number of selected component (if applicable):
----------------------------
5.6.0.6


How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Enable C&U collection for a provider.
2.Generate a Chargeback report 


Actual results:
--------------
No-zero chargeback costs when resource usage is zero.


Expected results:
-----------------
Chargeback costs should be zero when resource usage is zero.


Additional info:
----------------

Comment 2 Gregg Tanzillo 2016-05-31 16:23:27 UTC
https://github.com/ManageIQ/manageiq/pull/8862

Comment 3 Nandini Chandra 2016-06-12 14:56:08 UTC
Verified in 5.6.0.10

Comment 5 errata-xmlrpc 2016-06-29 16:04:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.