Bug 1337305 - [ceph-ansible] : ISO based installation failed in task 'install distro or red hat storage ceph mon' as it's looking for calamari repodata which is not present
Summary: [ceph-ansible] : ISO based installation failed in task 'install distro or red...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 18:55 UTC by Rachana Patel
Modified: 2016-08-23 19:51 UTC (History)
8 users (show)

Fixed In Version: ceph-ansible-1.0.5-15.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:51:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Rachana Patel 2016-05-18 18:55:06 UTC
Description of problem:
=======================
ISO based installation failed in task 'install distro or red hat storage ceph mon' with error
file:///tmp/rh-storage-repo/Calamari/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /tmp/rh-storage-repo/Calamari/repodata/repomd.xml"



Version-Release number of selected component (if applicable):
=============================================================
ceph-ansible-1.0.5-12.el7scon.noarch
ceph - 10.2.1-3.el7cp.x86_64.rpm


How reproducible:
================
always


Steps to Reproduce:
===================
1. perform prerequisite on all nodes
2. modify inventory file as below
[mons]
magna063
 
[osds]
magna084
magna085
magna090
 
[rgws]
magna100
 
3. modify below variable in 'all' and 'osds' file.

fetch_directory:
ceph_stable: true
ceph_stable_rh_storage: true
ceph_stable_rh_storage_iso_install: true # usually used when nodes don't have access to cdn.redhat.com
ceph_stable_rh_storage_iso_path: /root/iso/Ceph-2-RHEL-7-20160517.t.0-x86_64-dvd.iso
 public_network
cephx: true
monitor_interface: eno1
journal_size: 100
radosgw_civetweb_port: 8080

journal_collocation: true
crush_location: false
osd_crush_location: "'root={{ ceph_crush_root }} rack={{ ceph_crush_rack }} host={{ ansible_hostname }}'"
 
devices:
  - /dev/sdb
  - /dev/sdc


4. copy ISO on installer node and update iso_path accordingly in 'all' file

5. run below command 
[root@magna044 ceph-ansible]# ansible-playbook site.yml

Actual results:
===============
<snippet>

TASK: [ceph.ceph-common | add inktank ceph enterprise repository] ************* 
skipping: [magna063]

TASK: [ceph.ceph-common | add red hat storage repository] ********************* 
changed: [magna063]

TASK: [ceph.ceph-common | install ceph] *************************************** 
skipping: [magna063]

TASK: [ceph.ceph-common | set_fact ceph_stable_rel_pkg="{{ ceph_stable_releases | union([ 'infernalis' ]) }}"
] *** 
ok: [magna063]

TASK: [ceph.ceph-common | install distro or red hat storage ceph mon] ********* 
failed: [magna063] => {"failed": true}
msg: Error from repoquery: ['/usr/bin/repoquery', '--show-duplicates', '--plugins', '--quiet', '-q', '--disablerepo', '', '--enablerepo', '', '--qf', '%{name}-%{version}-%{release}.%{arch}', 'ceph-mon']: failure: repodata/repomd.xml from rh_storage_calamari: [Errno 256] No more mirrors to try.
file:///tmp/rh-storage-repo/Calamari/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /tmp/rh-storage-repo/Calamari/repodata/repomd.xml"
Could not match packages: failure: repodata/repomd.xml from rh_storage_calamari: [Errno 256] No more mirrors to try.
file:///tmp/rh-storage-repo/Calamari/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /tmp/rh-storage-repo/Calamari/repodata/repomd.xml"


FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/site.retry

magna063                   : ok=24   changed=6    unreachable=0    failed=1   



Additional info:
================
on MON node calamari Directory is not present.

[root@magna063 ubuntu]# ls -l /tmp/rh-storage-repo/
total 56
-r--r--r--. 1 root root  8774 May 18 17:34 EULA
-r--r--r--. 1 root root 18092 May 18 17:34 GPL
dr-xr-xr-x. 3 root root  4096 May 18 17:34 MON
dr-xr-xr-x. 3 root root  4096 May 18 17:34 OSD
-r--r--r--. 1 root root   165 May 18 17:34 README
-r--r--r--. 1 root root  3211 May 18 17:34 RPM-GPG-KEY-redhat-release
dr-xr-xr-x. 3 root root  4096 May 18 17:34 Tools
-r--r--r--. 1 root root  1976 May 18 17:34 TRANS.TBL
[root@magna063 ubuntu]#

Comment 3 Alfredo Deza 2016-05-19 19:30:38 UTC
Pull request opened https://github.com/ceph/ceph-ansible/pull/802

Comment 7 Rachana Patel 2016-07-27 01:57:08 UTC
verified with build
ceph-ansible-1.0.5-31.el7scon.noarch

Comment 9 errata-xmlrpc 2016-08-23 19:51:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.