Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Adding a new disk that will also need a new SCSI controller the VM Reconfigure Task fails with error "Invalid configuration for device '1'" Version-Release number of selected component (if applicable): 5.6.0.6 beta How reproducible: 100% Steps to Reproduce: 1. Create a VM with 15 disks 2. Add a new disk with CloudForms using the VM Reconfigure dialog Actual results: The task will fail with "Invalid configuration for device '1'" Expected results: The new disk as well as a new SCSI controller are added to the VM Additional info: The code to add a new SCSI controller when needed always puts the controller on bus 0. This will work if there are no SCSI controllers on the VM, but if additional controllers need to be added the next available bus number has to be used.
https://github.com/ManageIQ/manageiq/pull/8899
Verified in 5.7.0.0