Bug 1337310 - VMware VM Reconfigure Add Disk fails when a new SCSI controller is needed
Summary: VMware VM Reconfigure Add Disk fails when a new SCSI controller is needed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Adam Grare
QA Contact: luke couzens
URL:
Whiteboard: reconfigure:vmware
Depends On:
Blocks: 1346037 1358488
TreeView+ depends on / blocked
 
Reported: 2016-05-18 19:25 UTC by Adam Grare
Modified: 2020-12-11 12:12 UTC (History)
8 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1346037 1358488 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:20:09 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Adam Grare 2016-05-18 19:25:00 UTC
Description of problem:
Adding a new disk that will also need a new SCSI controller the VM Reconfigure Task fails with error "Invalid configuration for device '1'"

Version-Release number of selected component (if applicable):
5.6.0.6 beta

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with 15 disks
2. Add a new disk with CloudForms using the VM Reconfigure dialog

Actual results:
The task will fail with "Invalid configuration for device '1'"

Expected results:
The new disk as well as a new SCSI controller are added to the VM

Additional info:
The code to add a new SCSI controller when needed always puts the controller on bus 0.  This will work if there are no SCSI controllers on the VM, but if additional controllers need to be added the next available bus number has to be used.

Comment 2 Adam Grare 2016-06-03 13:37:53 UTC
https://github.com/ManageIQ/manageiq/pull/8899

Comment 6 luke couzens 2016-09-16 12:51:44 UTC
Verified in 5.7.0.0


Note You need to log in before you can comment on or make changes to this bug.