Bug 133736 - Can't start cups, can't config printers
Can't start cups, can't config printers
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-26 21:29 EDT by Peter S. Conrad
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 12:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter S. Conrad 2004-09-26 21:29:39 EDT
Description of problem:
The first time I installed my printer, everything worked fine.
Eventually, by magic, it stopped working. Printing anything would
result in "server-error-service-unavailable." Opening the gnome GUI
tool for configuring or managing printers would just freeze. So I went
to a shell and tried restarting cups, and it said: Child exited with
status 99! So I uninstalled and reinstalled cups, and my results are
the same. 

In between things working and things magically not working, all I did
was the up2date automated update.

Version-Release number of selected component (if applicable):
cups-1.1.20-11.1


How reproducible:
print, or try to restart cups from a shell, or try to use either the
print manager or the printer configuration tool

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Eventually, error-service unavailable, or "Child exited with status
99!" or a print configurator/manager window with no contents that
doesn't respond or close 

Expected results:
Lovely paper with ink selectively arranged thereupon

Additional info:
Thinkpad t20, Epson Stylus 820, new hard drive, no other weird
behavior to report, all pretty normal software (no crazy hacks, no dev
kernel, no shady apps).
Comment 1 Peter S. Conrad 2004-09-26 21:36:01 EDT
Note: Mozilla never sees the printer. Even in cases where the Printer
Configuration GUI finally sees the printer (which I named SP820)
Mozilla only sees default/postscript. I don't know if that's a clue.
And Ximian Evolution just hangs if I tell it to print.
Comment 2 Tim Waugh 2004-10-08 06:02:59 EDT
Please alter the LogLevel line in /etc/cups/cupsd.conf to say:

LogLevel debug2

Then restart CUPS with: /sbin/service cups restart

What are the last few lines of /var/log/cups/error_log?
Comment 3 Peter S. Conrad 2004-10-08 17:41:33 EDT
Unfortunately, I ended up having to reinstall cups to solve an
OpenOffice problem-- so the errors are lost. I'll have to try again
and see if it fails (haven't even tried to print from this machine
since the problem happened before I reinstalled).
Comment 4 Tim Waugh 2004-10-08 18:25:44 EDT
Okay.
Comment 5 Marc Vogt 2004-11-27 03:36:58 EST
Same problem here with cups-1.1.22-0.rc1.8

<snip>
After the above suggestion /var/log/cups/error_log reads 

D [27/Nov/2004:03:34:09 -0500] LoadDevices: Added device
"usb:/dev/usb/lp15"...
I [27/Nov/2004:03:34:09 -0500] LoadPPDs: Read "/etc/cups/ppds.dat", 15
PPDs...
I [27/Nov/2004:03:34:09 -0500] LoadPPDs: No new or changed PPDs...
D [27/Nov/2004:03:34:09 -0500] LoadAllJobs: Scanning /var/spool/cups...
I [27/Nov/2004:03:34:09 -0500] Full reload complete.
D [27/Nov/2004:03:34:09 -0500] StartListening: NumListeners=1
D [27/Nov/2004:03:34:09 -0500] StartListening: address=7f000001 port=631
E [27/Nov/2004:03:34:09 -0500] StartListening: Unable to bind socket
for address 7f000001:631 - Cannot assign requested address.
Comment 6 Tim Waugh 2004-11-29 11:12:28 EST
Peter -- is this anything to do with what you saw?
Comment 7 Peter S. Conrad 2004-11-29 12:26:58 EST
I didn't read /var/log/cups/error_log unfortunately. Interestingly enough,
having reinstalled (as noted above) I now have a totally different problem-- I
can config the printer, unless the printer is actually plugged into the laptop,
at which point it disappears from the Printer Configuration Tool. So I do all my
printing by copying a PDF to an SD card and printing from my Mac... :(

BTW if I didn't have to do that, and once I get the gstreamer module installed
on the CD ripping tool, I guess my move from Mac to Linux will be complete.
Comment 8 Tim Waugh 2004-11-29 12:45:38 EST
Please file a separate bug report for that: as you noted, it's a totally
different problem.

Closing.

Note You need to log in before you can comment on or make changes to this bug.