Bug 133737 - Cannot unmount without eject
Summary: Cannot unmount without eject
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 01:58 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 08:01:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2004-09-27 01:58:12 UTC
Description of problem:
The GUI interface seems to lack any way of unmounting a disc without
ejecting.  The only way to do it is manually from a command line. 
Unmount without eject is necessary for cases like vmware.

Version-Release number of selected component (if applicable):
nautilus-2.8.0-1

Comment 1 Alexander Larsson 2004-09-28 09:36:36 UTC
Why is this needed for vmware? It seems like an very unnecessary and
actively confusing feature to me.

Comment 2 Warren Togami 2004-09-28 09:40:34 UTC
vmware is unable to use the disc if the host OS mounted it.

A more concrete (and should be supported) example is...
1) User inserts CD-RW, wanting to blank it using one of the CD-R GUI
tools.
2) It fails, because the system has the disc mounted.
3) GUI can only Eject, unable to unmount without Eject.

Comment 3 Bill Nottingham 2004-09-29 02:52:44 UTC
Well, #2 won't actually happen due to other bugs. :)

Comment 4 Alexander Larsson 2004-09-29 08:01:11 UTC
Well, the burning app should "just work" by unmounting the CD, we
should n't push these implementation details on the user, forcing them
to learn  the differences between eject and unmount of a cd, and
filling up the menus with basically-equivalent operations.

Comment 5 Ray Strode [halfline] 2004-09-29 14:10:19 UTC
Is this a case where CD-RW blanking programs should use the new HAL
locking code?

Comment 6 Alexander Larsson 2004-09-29 14:58:34 UTC
You might have inserted the CD-RW before even starting the blanking
program. In fact, if the blanking app is started by right-clicking on
the disc in computer and selecting "blank", this is always true.


Note You need to log in before you can comment on or make changes to this bug.