Bug 133738 - firefox debuginfo is empty
firefox debuginfo is empty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-26 21:59 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 22:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-09-26 21:59:56 EDT
Description of problem:
firefox debuginfo is empty/broken.
Comment 1 Christopher Aillon 2004-09-27 14:59:59 EDT
That's because we aren't disabling stripping of the libs.  So they get
stripped before we get to turn them into debuginfo rpms.
Comment 2 Nicholas Miell 2004-09-27 22:19:24 EDT
Stripping is disabled by default, however the
xpinstall/packager/Makefile strips everything when it builds the
package, regardless of how you configure it.

Change the following line in the RPM spec:
%{__make} MOZILLA_BIN="\$(DIST)/bin/firefox-bin"
to:
%{__make} MOZILLA_BIN="\$(DIST)/bin/firefox-bin" STRIP="/bin/true"
and the problem goes away.
Comment 3 Christopher Aillon 2004-09-28 22:52:16 EDT
This got fixed yesterday in rawhide.

Note You need to log in before you can comment on or make changes to this bug.