Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337415 - disk devices need to be identified by their UUID
Summary: disk devices need to be identified by their UUID
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: 3
Assignee: Shubhendu Tripathi
QA Contact: sds-qe-bugs
URL:
Whiteboard:
: 1337417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 07:22 UTC by Jeff Applewhite
Modified: 2017-03-23 04:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 04:06:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 279320 0 None None None 2016-06-22 10:30:12 UTC

Description Jeff Applewhite 2016-05-19 07:22:54 UTC
Description of problem:
There is a risk of a node having multiple disks and losing a disk then another disk will take it's device name. 

Ex. 

/dev/sda
/dev/sdb
/dev/sdc
/dev/sdd

Now /dev/sdc fails. The host reboots. What will happen is that /dev/sdd will now have the identifier /dev/sdc which will cause problems in our handling of the disks.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Fail a disk. 
2. Roboot the host 
3. watch that the disks will be re-ordered


Actual results:


Expected results:
We should refer to disks by their unique id that can be found at /dev/disk/by-uuid/<uuid> because this does not change on reboot.

Additional info:

Comment 2 Nishanth Thomas 2016-05-24 06:53:19 UTC
*** Bug 1337417 has been marked as a duplicate of this bug. ***

Comment 4 Shubhendu Tripathi 2016-07-15 11:27:15 UTC
Jeff, I tried doing a patch and impact seems to be more and all the flows would be required to be verified as well.

Also, it would be certainly risky at this moment to change something at framework level.

So Nishanth suggested for 3.0..


Note You need to log in before you can comment on or make changes to this bug.