Bug 1337484 - EOF is not handled for ipa-client-install command
Summary: EOF is not handled for ipa-client-install command
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 10:01 UTC by Sudhir Menon
Modified: 2016-11-04 05:54 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:54:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-05-19 10:01:44 UTC
Description of problem: EOF is not handled for ipa-client-install command


Version-Release number of selected component (if applicable):
ipa-client-4.2.0-15.el7_2.15.x86_64

How reproducible:Always


Steps to Reproduce:
1. Ensure ipa-client rpm is installed
2. echo "Some sample text" | ipa-client-install 

Actual results:
    [root@client ipapython]# echo "Some sample text" | ipa-client-install
    Discovery was successful!
    Client hostname: client.testrelm.test
    Realm: TESTRELM.TEST
    DNS Domain: testrelm.test
    IPA Server: master.testrelm.test
    BaseDN: dc=testrelm,dc=test
     
    Continue to configure the system with these values? [no]: Continue to configure the system with these values? [no]: Traceback (most recent call last):
      File "/usr/sbin/ipa-client-install", line 3102, in <module>
        sys.exit(main())
      File "/usr/sbin/ipa-client-install", line 3083, in main
        rval = install(options, env, fstore, statestore)
      File "/usr/sbin/ipa-client-install", line 2470, in install
        if not options.unattended and not user_input("Continue to configure the system with these values?", False):
      File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 766, in user_input
        ret = raw_input("%s [%s]: " % (prompt, choice))
    EOFError: EOF when reading a line


Expected results:EOF should be handled.


Additional info:https://fedorahosted.org/freeipa/ticket/3406

Comment 1 Petr Vobornik 2016-05-19 10:38:50 UTC
As mention above(#3406), it should be fixed in FreeIPA 4.3.

Comment 2 Martin Bašti 2016-05-25 13:15:41 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3406

Comment 4 Sudhir Menon 2016-07-18 10:09:07 UTC
EOF is handled now. 
Verified using ipa-client-4.4.0-2.1.el7.x86_64

[root@client ~]# echo "Somesampletext" | ipa-client-install 
WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

Discovery was successful!
Client hostname: client.testrelm.test
Realm: TESTRELM.TEST
DNS Domain: testrelm.test
IPA Server: server.testrelm.test
BaseDN: dc=testrelm,dc=test

Installation failed. Rolling back changes.
IPA client is not configured on this system.
Continue to configure the system with these values? [no]: 
Continue to configure the system with these values? [no]: 
[root@client ~]#

Comment 6 errata-xmlrpc 2016-11-04 05:54:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.