Bug 133749 - Call "alsactl store" only if there is a sound card loaded
Call "alsactl store" only if there is a sound card loaded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-27 02:46 EDT by Féliciano Matias
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 17:57:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A little patch (414 bytes, patch)
2004-09-27 02:47 EDT, Féliciano Matias
no flags Details | Diff

  None (edit)
Description Féliciano Matias 2004-09-27 02:46:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
/etc/rc.d/init.d/halt only check if the kernel provide alsa and then
store the current mixer setting.
But alsa can be loaded without a soundcard. This can erase
/etc/asound.state.

Version-Release number of selected component (if applicable):
initscripts-7.84-1

How reproducible:
Always

Steps to Reproduce:
halt or reboot.

Additional info:

It's not really a initscript bug.
The problem is that /dev/snd/controlC0 (and
/sys/class/sound/controlC0) are in place even if there is no sound card.
This seems to be a alsa-driver bug.
Comment 1 Féliciano Matias 2004-09-27 02:47:20 EDT
Created attachment 104348 [details]
A little patch
Comment 2 Bill Nottingham 2004-09-28 22:59:51 EDT
Out of curiousity, when are you seeing alsa loaded without a soundcard?
Comment 3 Bill Nottingham 2004-09-28 23:00:46 EDT
Note that this won't work if you have a machine with only, say,
snd-intel8x0m loaded.
Comment 4 Féliciano Matias 2004-09-29 01:10:27 EDT
> Out of curiousity, when are you seeing alsa loaded without a soundcard?

With snd-dummy :-)

Never but who knows.

I was playing with "modprobe snd-xxxx" and "modprobe -r snd-xxxx" to
find out why sound setting is lose.
Find two cases :
- when sound setting is not restore (modprobe) and then after store
(with halt or "modprobe -r").
- When no sound card is loaded.

I repeat, it's not an initscript or alsactl bug.
It seems to me it's a kernel/alsa-driver bug.

If there is no sound card, then there shounld not be
/dev/snd/controlCX (udev) or device and then "alsactl store" should
failed.

But it's not what I see here (snd-ens1371 and snd-via82xx).

> Note that this won't work if you have a machine with only, say,
snd-intel8x0m loaded.

???
$ modinfo snd-intel8x0m.ko  | grep depends
depends:        snd-ac97-codec,snd-pcm,snd-page-alloc,snd

Why do you want to use alsactl if the card is not under the umbrella
of alsa ?

Anyway, if you want to close this bug with NOTABUG and drop my
fabulous patch, do it. Again, it's not an initscript bug.

Sorry for the noise.
Comment 5 Bill Nottingham 2004-09-29 01:23:01 EDT
What I mean is that if snd-intel8x0m is loaded, it will show as a
'card', but there's no audio settings to save for that device. :)
Comment 6 Bill Nottingham 2004-10-14 17:57:29 EDT
OK, closing as NOTABUG for now. With the new alsa-utils with the udev
fix, things *should* work correctly, as long as a initial volume is
set somewhere.

Note You need to log in before you can comment on or make changes to this bug.