Bug 1337511 - Property error: resources.ManagementNetwork.properties.ManagementNetValueSpecs: Value must be a string
Summary: Property error: resources.ManagementNetwork.properties.ManagementNetValueSpec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Jiri Stransky
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 11:20 UTC by Marius Cornea
Modified: 2016-08-16 04:13 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-9.el7ost
Doc Type: Bug Fix
Doc Text:
The ManagementNetValueSpecs parameter used the wrong type (string) in the director's Heat templates. This caused Overcloud deployments containing the Management network to fail with the following error: "Property error: resources.ManagementNetwork.properties.ManagementNetValueSpecs: Value must be a string". This fix changes the data type of ManagementNetValueSpecs from string to json. The error no longer appears.
Clone Of:
Environment:
Last Closed: 2016-08-11 11:30:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Marius Cornea 2016-05-19 11:20:17 UTC
Description of problem:
Deployment that includes a management network fails with:

Property error: resources.ManagementNetwork.properties.ManagementNetValueSpecs: Value must be a string

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud that includes a management network

Actual results:
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
2016-05-19 11:12:18 [overcloud]: CREATE_IN_PROGRESS Stack CREATE started
2016-05-19 11:12:18 [Networks]: CREATE_IN_PROGRESS state changed
2016-05-19 11:12:18 [Networks]: CREATE_FAILED resources.Networks: Property error: resources.ManagementNetwork.properties.ManagementNetValueSpecs: Value must be a string
2016-05-19 11:12:18 [overcloud]: CREATE_FAILED Resource CREATE failed: resources.Networks: Property error: resources.ManagementNetwork.properties.ManagementNetValueSpecs: Value must be a string
Stack overcloud CREATE_FAILED
Deployment failed:  Heat Stack create failed.


Expected results:
Deployment continues.

Additional info:
Upstream bug:
https://bugs.launchpad.net/tripleo/+bug/1573649

Fix:
https://review.openstack.org/#/c/309468/

Comment 5 Marius Cornea 2016-07-27 08:20:41 UTC
[root@undercloud ~]# rpm -qa | grep tripleo-heat-templates
openstack-tripleo-heat-templates-kilo-2.0.0-16.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-16.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-16.el7ost.noarch

[root@undercloud ~]# grep -A3 ManagementNetValueSpecs: /usr/share/openstack-tripleo-heat-templates/network/management.yaml 
  ManagementNetValueSpecs:
    default: {'provider:physical_network': 'management', 'provider:network_type': 'flat'}
    description: Value specs for the management network.
    type: json

Comment 7 errata-xmlrpc 2016-08-11 11:30:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.