Bug 1337553 - externalIPNetworkCIDR not added in master-config [NEEDINFO]
Summary: externalIPNetworkCIDR not added in master-config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Samuel Munilla
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 12:44 UTC by Jaspreet Kaur
Modified: 2016-11-29 06:59 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:32:58 UTC
Target Upstream Version:
mfojtik: needinfo? (ccoleman)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Jaspreet Kaur 2016-05-19 12:44:00 UTC
Description of problem: externalIPNetworkCIDR was introduced in release 3.2 but can not be set from the ansible installer.
Also, As per the documentation :

The new networkConfig.externalIPNetworkCIDR parameter has been added to the master-config.yaml file to control the allowable values for external IPs. By default, it is empty, which rejects all values. Cluster administrators can set it to 0.0.0.0/0 to emulate the behavior from OpenShift Enterprise 3.1.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Installed 3.2 
2. the parameter is not there in /etc/origin/master/master-config.yaml
3. Also, this cannot be set from the ansible installer.

Actual results:  The parameter is not there to make if effective


Expected results: It should be there as the feature is clearly released-notes


Additional info:

Comment 1 Michal Fojtik 2016-05-19 15:59:57 UTC
I believe the behavior was changed in this commit:

https://github.com/openshift/origin/pull/7810/files#diff-381e09db7a55a712234f2c2413f7d987R315

I think the correct option name is 'externalIPNetworkCIDRs' (note the 's')? 
Clayton?

Comment 2 Michal Fojtik 2016-05-19 16:01:25 UTC
Jaspreet can you confirm that you use the correct option?

Comment 3 Jason DeTiberus 2016-05-19 16:18:39 UTC
Current plan is to do the following:
- Add support for configuring externalIPNetworkCIDRs to openshift-ansible
- For 3.1 to 3.2 upgrades, set externalIPNetworkCIDRs to 0.0.0.0/0 (and persist the value in openshift-facts) to maintain the previous behavior
- For new 3.2 installs, Only set externalIPNetworkCIDRs when the user specifies a value.

Comment 7 Gaoyun Pei 2016-08-25 04:00:09 UTC
Verify this bug with openshift-ansible-3.3.15-1.git.0.a9fd72e.el7 rpm package

Without setting openshift_master_external_ip_network_cidrs option in ansible inventory, externalIPNetworkCIDRs would be set as "0.0.0.0/0" by default
...
  externalIPNetworkCIDRs: 
  - 0.0.0.0/0


With setting openshift_master_external_ip_network_cidrs=['10.100.0.0/16'] in inventory file, openshift-ansible will configure this IP range in master-config.yaml
...
  externalIPNetworkCIDRs:
  - 10.100.0.0/16

Comment 9 errata-xmlrpc 2016-09-27 09:32:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.