Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337563 - [ja_JP] Drop down menu translations missing on Settings-Tasks page.
Summary: [ja_JP] Drop down menu translations missing on Settings-Tasks page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Milan Zázrivec
QA Contact: Krishna Babu K
URL:
Whiteboard: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 13:20 UTC by Krishna Babu K
Modified: 2017-08-30 01:31 UTC (History)
9 users (show)

Fixed In Version: 5.6.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 16:04:26 UTC
Category: Bug
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screen shot references for the reported issue. (315.50 KB, application/x-tar)
2016-05-19 13:20 UTC, Krishna Babu K
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Krishna Babu K 2016-05-19 13:20:39 UTC
Created attachment 1159476 [details]
Screen shot references for the reported issue.

Description of problem:
  Translations are missing in drop down menus 'Zone', '24 Hour Time Period' and 'Task State' at Settings->Tasks->My Vm and Container Analysis Tasks tab.

Version-Release number of selected component (if applicable):
   5.6.0.7-beta2.6

How reproducible:
  Always


Steps to Reproduce:
1. Login to cfme with ja_JP locale.
2. Navigate to Settings->Tasks->My Vm and Container Analysis Tasks tab.
3. Click on 'Zone', '24 Hour Time Period' and 'Task State' menus.

Actual results:
  Translations are missing.

Expected results:
  Translations should available.

Additional info:
  Screenshot attached.

Comment 2 Milan Zázrivec 2016-05-20 11:59:21 UTC
Valid bug, which won't require any additional translator work.

https://github.com/ManageIQ/manageiq/pull/8848

Comment 3 CFME Bot 2016-05-20 13:41:33 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/4a91b4ea3a2325a6fbae7963a4e46f6c2d717852

commit 4a91b4ea3a2325a6fbae7963a4e46f6c2d717852
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Fri May 20 13:55:26 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Fri May 20 13:55:26 2016 +0200

    UI constants need to be ran through gettext dynamically
    
    UI constants are loaded to the appliance at startup
    and won't be re-evaluated again, so we need to use N_() for
    these strings and use _() dynamically whenever they're being
    used.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1337563

 app/helpers/ui_constants.rb                 | 28 ++++++++++++++--------------
 app/views/miq_task/_tasks_options.html.haml |  4 ++--
 2 files changed, 16 insertions(+), 16 deletions(-)

Comment 5 Krishna Babu K 2016-06-17 10:39:37 UTC
Verified on 5.6.0.10-rc2.1. Translations are available.
Moving it to Verified as of now.

Comment 7 errata-xmlrpc 2016-06-29 16:04:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.