Bug 1337569 - SMB: Getting error with upgrade and net join ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Summary: SMB: Getting error with upgrade and net join ldb: unable to stat module /usr/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.1.3
Assignee: Jose A. Rivera
QA Contact: surabhi
URL:
Whiteboard:
Depends On:
Blocks: 1311817
TreeView+ depends on / blocked
 
Reported: 2016-05-19 13:48 UTC by surabhi
Modified: 2016-06-23 05:37 UTC (History)
4 users (show)

Fixed In Version: samba-4.4.3-6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-23 05:37:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1245 0 normal SHIPPED_LIVE gluster-smb bug fix and enhancement update 2016-06-23 09:13:06 UTC

Description surabhi 2016-05-19 13:48:16 UTC
Description of problem:
******************************
While doing net ads join saw following message which doesn't see related to 
AD but look like an issue in spec file with the location of ldb.

the error says we are looking for ldb at /usr/lib64/samba/ldb:

ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
but actually it is present in following location.

find / -name ldb
/usr/lib/debug/usr/lib64/samba/ldb
/usr/lib64/ldb
/usr/lib64/ldb/modules/ldb
/usr/src/debug/samba-4.4.3/source4/torture/ldb

net ads join -U Administrator
Enter Administrator's password:
ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Using short domain name -- RHSQE-2008-DC
Joined 'RHS-SMB' to dns domain 'rhsqe-2008-dc.com'


Version-Release number of selected component (if applicable):
samba-4.4.3-3.el7rhgs.x86_64

How reproducible:
always

Steps to Reproduce:
1. On above mentioned samba version , configure AD and try to do net ads join -U user
2.Observe any error
3. Or Do Upgrade from RHGS 3.1.2 to 3.1.3

Actual results:

It gives an error ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory

No issue with AD 


Expected results:
We should not see such error. Looks like the stat is for ldb is done on wrong location.

Additional info:

Comment 5 surabhi 2016-05-30 07:47:33 UTC
After updating to samba version samba-4.4.3-6.el7rhgs.x86_64 , configuring Active directory with samba and executing net join doesn't give any error messages related to ldb.Marking the BZ verified.

Comment 7 errata-xmlrpc 2016-06-23 05:37:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1245


Note You need to log in before you can comment on or make changes to this bug.