Bug 133759 - adap kudzu to udev and improve index sound card
adap kudzu to udev and improve index sound card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-09-27 06:55 EDT by Féliciano Matias
Modified: 2014-03-16 22:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.113-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 14:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
improve index sound card (2.35 KB, patch)
2004-09-27 06:58 EDT, Féliciano Matias
no flags Details | Diff

  None (edit)
Description Féliciano Matias 2004-09-27 06:55:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
This is what it is currently push by kudzu to configure sound card :

alias snd-card-1 snd-via82xx
options snd-card-1 index=1
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx



If "modprobe snd-via82xx" is done then "index=1" is not honored.

"alsactl restore" failed if udev is enabled. See #133535 .

Version-Release number of selected component (if applicable):
kudzu-1.1.90-1

How reproducible:
Always

Steps to Reproduce:
modprobe the second card first (like initscrips does in my system).
That is :
snd-ens1371 => snd-card-0
snd-via82xx => snd-card-1

At boot time, initscript does "modprobe snd-via82xx" before "modprobe
snd-ens1371".

Actual Results:
$ cat /proc/asound/cards
0 [V8233Pre       ]: VIA8233 - VIA 8233-Pre
                     VIA 8233-Pre at 0xd400, irq 4


Expected Results:
$ cat /proc/asound/cards
1 [V8233Pre       ]: VIA8233 - VIA 8233-Pre
                     VIA 8233-Pre at 0xd400, irq 4


Additional info:

With udev the following line in modprobe.conf is useless :
install snd-XXXX /sbin/modprobe --ignore-install snd-XXXX &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
Comment 1 Féliciano Matias 2004-09-27 06:58:18 EDT
Created attachment 104360 [details]
improve index sound card

Add :
options snd-XXXX index=n

remove :
install snd-XXXX /sbin/modprobe ...
Comment 2 Féliciano Matias 2004-09-27 07:08:51 EDT
Since FC3 use udev, "alias snd-card-X snd-XXXX" is useless.
snd-card-X is used to autoload module. But udev does not feet with
autoloading.

Also, "remove <module>..." in modprobe.conf does not support alias. So
"modprobe -r snd-card-X" does not store the setting of the card.

Perhaps it's time to remove this alias.

The previous patch change module_upgrade.c . I don't test module_upgrade.
Comment 3 Bill Nottingham 2004-09-27 12:04:56 EDT
"remove <module>" it's intentional that it doesn't support alias.
Nothing will ever call 'modprobe -r snd-card-X',  AFAIK; things will
only remove the specific module. (and that's rare enough.)
Comment 4 Féliciano Matias 2004-09-27 13:56:02 EDT
So, why to keep "alias snd-card-X ...." ?

This alias is interesting in one case (AFAIK) :
$ modprobe -c | grep "alias.*snd-card-" | cut -f 3 -d ' '
snd-ens1371
snd-via82xx

kmodule also provide these informations :
$ kmodule | grep AUDIO | cut -f 2 -d ' '
snd-via82xx
snd-ens1371

Before udev (with a static /dev) this alias was usefull for
autoloading sound modules. With udev we have to explicitly load the
module (initscript, modprobe, etc).
Comment 5 Bill Nottingham 2005-04-22 14:29:13 EDT
A version of this added in 1.1.112-1.
Comment 6 Bill Nottingham 2005-04-22 18:26:41 EDT
Oops, 1.1.113-1.

Note You need to log in before you can comment on or make changes to this bug.