Bug 133763 - OpenOffice.org fonts are ghastly in cy_GB.UTF-8
OpenOffice.org fonts are ghastly in cy_GB.UTF-8
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 07:25 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-09-27 07:25:27 EDT
While Gnome and KDE are finding nice fonts for cy_GB (Welsh) the
OpenOffice package is using something I don't recognize that is not
very nice at all. This is a default desktop install.

Welsh does need accented vowels outside ISO8859-1/15 code space (Ŵ, Ŷ)
which means that it cannot use vera fonts (there is a patched vera to
fix this 'Olwen'), however it then seems to pick different fonts to
the desktop.
Comment 1 Dan Williams 2004-09-28 13:35:44 EDT
It should not be using the Vera fonts.  It should be using Nimbus
roman no 9L.

So, some questions:
1) Are you talking about the UI font, or the default Writer font, or what?
2) What exact version of OOo (rpm version, I mean)
Comment 2 Alan Cox 2004-09-28 13:50:36 EDT
The UI font. 

LANG=en_GB.UTF-8 oowriter - nice fonts
LANG=cy_GB.UTF-8 oowriter - looks like a monospace bitmap font

Also both log an error 
"Use of uninitialized variable in string in /usr/bin/oowriter at line 335"
 if that is relevant

This is straight off the CD for FC3t2. The box is chewing away at
updating at the moment.
Comment 3 Dan Williams 2004-09-29 15:47:24 EDT
OOo does not use X11 bitmapped fonts.  When it attempts to get the UI
font to use, fontconfig tells OOo to use LucidaTypewriter, which is a
bitmap font.  OOo then substitutes another font, probably Courier, for
LucidaTypewriter because OOo will not use bitmap fonts.

I'm not going to fix that at this time, but if you feel that another
font on the system that we ship _has_ all the require characters (for
example, the Nimbus ones), please file a bug against Fontconfig for this.

Note You need to log in before you can comment on or make changes to this bug.