Bug 1337669 - [RFE] [Sahara] Package Sahara UI plugin to Horizon (openstack-sahara-ui)
Summary: [RFE] [Sahara] Package Sahara UI plugin to Horizon (openstack-sahara-ui)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara-ui
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 10.0 (Newton)
Assignee: Elise Gafford
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 18:52 UTC by Rob Young
Modified: 2016-12-14 15:34 UTC (History)
8 users (show)

Fixed In Version: openstack-sahara-ui-4.0.0-0.20160517071351.4a67a2c.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1341313 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:34:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Rob Young 2016-05-19 18:52:04 UTC
Description of problem:

Package, test Sahara UI plugin to Horizon (openstack-sahara-ui). This will provide a user-friendly alternative to the Sahara CLI and will enable Horizon users to manage their Sahara deployment using a standard UI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Luigi Toscano 2016-11-03 18:53:46 UTC
The Sahara UI is packaged. When the package is installed and Sahara is enabled, it shows up in Horizon ("Data Processing") and the tabs can be accessed.

Verified on:
openstack-sahara-ui-5.0.0-3.el7ost.noarch
python-saharaclient-0.18.0-1.el7ost.noarch
openstack-dashboard-10.0.0-6.el7ost.noarch
openstack-dashboard-theme-10.0.0-6.el7ost.noarch
openstack-sahara-api-5.0.0-3.el7ost.noarch
openstack-sahara-common-5.0.0-3.el7ost.noarch
openstack-sahara-engine-5.0.0-3.el7ost.noarch
python-sahara-5.0.0-3.el7ost.noarch

Comment 6 errata-xmlrpc 2016-12-14 15:34:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.