Bug 1337698 - [RFE] Provider UI: GCE, add a file upload input for service account information
Summary: [RFE] Provider UI: GCE, add a file upload input for service account information
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Dave Johnson
URL:
Whiteboard: ui:provider:google
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 20:47 UTC by Taras Lehinevych
Modified: 2017-08-28 14:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 14:50:47 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Taras Lehinevych 2016-05-19 20:47:01 UTC
Description of problem:
GCE credentials (service account data) is saved into json file. We should add an option to upload this file. Currently only copy (from json file) paste (into text input) is available. 

Version-Release number of selected component (if applicable):
5.6.0.7

How reproducible:
Always

Steps to Reproduce:
1) Go to Compute -> Cloud -> Providers 
1) Press Configuration -> Add a New Cloud Provider
2) Choose type Google Compute Engine
3)

Actual results:
Unable to upload the service account json file.

Expected results:
A file upload input option should be available

Additional info:
The json file contains a lot of information and private key what make impossible to read, correct or enter manually any data in "Service Account JSON" input. Only copy & paste is an option.

Comment 6 Chris Pelland 2017-08-28 14:50:47 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.