Bug 133770 - OpenLDAP Replication + MultiMaster
Summary: OpenLDAP Replication + MultiMaster
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openldap   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 155282
TreeView+ depends on / blocked
 
Reported: 2004-09-27 11:47 UTC by Sameh Attia
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:17:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sameh Attia 2004-09-27 11:47:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040923

Description of problem:
OpenLDAP is being compiled by Red Hat without multimaster support.
In a clustered-highly-available LDAP setup a master/slave relation
wont help because slaves cant update; they become usefull with read only.

In a multimaster scenario we can build a highly available cluster if
and only if multimaster is enabled.


Version-Release number of selected component (if applicable):
openldap-2.0.27-17

How reproducible:
Always

Steps to Reproduce:
1. setup ldap with master/slave replication
2. talk to the slave only and update any attribute
3. if ur client doesnt talk referrals, which is the case with most
apps, or the master is down, then u get a master/slave incompatible
replicas.
    

Additional info:

Comment 3 Mohamed Eldesoky 2004-12-15 15:25:39 UTC
Any progress ????


Comment 4 Suzanne Hillman 2005-04-18 19:11:06 UTC
Internal RFE bug #155282 entered; will be considered for future releases.

Comment 5 RHEL Product and Program Management 2007-10-19 19:17:37 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.