Bug 1337846 - Upgrade[619 -> sat62 snap12] candlepin logs raises ERROR Unable to instantiate AMQPBusProvider
Summary: Upgrade[619 -> sat62 snap12] candlepin logs raises ERROR Unable to instantiat...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Upgrades
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks: 1335807
TreeView+ depends on / blocked
 
Reported: 2016-05-20 08:39 UTC by Sachin Ghai
Modified: 2019-04-01 20:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-26 09:13:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
complete exception (16.85 KB, text/plain)
2016-05-20 08:39 UTC, Sachin Ghai
no flags Details
foreman-debug logs (1.04 MB, application/x-xz)
2016-05-20 09:41 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2016-05-20 08:39:04 UTC
Description of problem:
I was trying upgrade from [619 -> sat62 snap12] and performed following steps:

1. Disable sat6.1 repo 
2. Set/enable sat6.2 repo
3. yum install satellite -y
4. yum update -y
5. satellite-installer --scenario satellite --upgrade 

While installer was running, following exception raised in candlepin logs:

==> /var/log/candlepin/candlepin.log <==
2016-05-20 04:18:39,208 [thread=localhost-startStop-1] [=, org=] ERROR org.candlepin.guice.AMQPBusPubProvider - Unable to instantiate AMQPBusProvider: 
javax.jms.JMSException: Error creating connection: Connection refused
	at org.apache.qpid.client.AMQConnectionFactory.createConnection(AMQConnectionFactory.java:128) ~[qpid-client-0.30.jar:0.30]
	at org.candlepin.guice.AMQPBusPubProvider.init(AMQPBusPubProvider.java:84) ~[AMQPBusPubProvider.class:na]
	at org.candlepin.guice.AMQPBusPubProvider.<init>(AMQPBusPubProvider.java:73) ~[AMQPBusPubProvider.class:na]
	at org.candlepin.guice.AMQPBusPubProvider$$FastClassByGuice$$ef75a35a.newInstance(<generated>) [guice-3.0.jar:na]
	at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40) [guice-3.0.jar:na]
	at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:60) [guice-3.0.jar:na]
	at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:85) [guice-3.0.jar:

Version-Release number of selected component (if applicable):
Upgrade[ sat619 -> sat62 snap12]

How reproducible:


Steps to Reproduce:
1. Disable sat6.1 repo 
2. Set/enable sat6.2 repo
3. yum install satellite -y
4. yum update -y
5. satellite-installer --scenario satellite --upgrade 

Actual results:

2016-05-20 04:18:39,208 [thread=localhost-startStop-1] [=, org=] ERROR org.candlepin.guice.AMQPBusPubProvider - Unable to instantiate AMQPBusProvider: 
javax.jms.JMSException: Error creating connection: Connection refused
	at org.apache.qpid.client.AMQConnectionFactory.createConnection(AMQConnectionFactory.java:128) ~[qpid-client-0.30.jar:0.30]
	at org.candlepin.guice.AMQPBusPubProvider.init(AMQPBusPubProvider.java:84) ~[AMQPBusPubProvider.class:na

Expected results:
no execption should be raised in logs while running upgrade.

Additional info:

Comment 1 Sachin Ghai 2016-05-20 08:39:53 UTC
Created attachment 1159848 [details]
complete exception

Comment 2 Sachin Ghai 2016-05-20 09:41:35 UTC
Created attachment 1159864 [details]
foreman-debug logs

Comment 4 Brad Buckingham 2016-05-24 14:49:08 UTC
I have not been able to reproduce this issue on my environment.  I am testing with changes that will be coming in snap 13; therefore, it could be related to those changes or environmental or procedural differences.  For now, I am going to triage this in, as we need to ensure the bug is resolved.

Comment 5 Sachin Ghai 2016-05-26 09:13:41 UTC
This issue appears only when we run "yum install satellite -y" before "yum update -y". Otherwise not reproducible. I'm closing this issue now because as per dev satellite package installed with yum update -y so no need to install satellite package before yum update. I will re-open if come across again with standard upgrade procedure.


Note You need to log in before you can comment on or make changes to this bug.