Bug 1337854 - Activation key created by user is removed when user is deleted
Summary: Activation key created by user is removed when user is deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys
Version: 6.1.8
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-20 09:10 UTC by Marcel Gazdík
Modified: 2019-11-14 08:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:03:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification video (1.66 MB, application/octet-stream)
2016-09-19 19:43 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1938 normal SHIPPED_LIVE Satellite 6.1.10 bug fix update 2016-09-27 12:56:10 UTC
Foreman Issue Tracker 12804 None None None 2016-06-13 15:17:57 UTC

Description Marcel Gazdík 2016-05-20 09:10:39 UTC
Description of problem:
  When you have created an activation key with some specific user, lets say TEST and when you remove/delete the user even the activation key is being removed along with that user.

Version-Release number of selected component (if applicable):
6.1.X


Steps to Reproduce:
1. Create a user in WebUI 
2. Login with that user and create activation key
3. Verify the activation exists
4. Login as the admin user
5. remove the user created in step 1.
6. Verify the activation key exist

Actual results:
  Activation key will be removed

Expected results:
  Activation key shouldn't be removed.

Comment 2 Kenny Tordeurs 2016-06-10 09:26:22 UTC
Hi,

I have changed the priority to urgent seeing as this is a very big downside for customers as there is no warning when deleting the user account that the created Activation Keys also will be deleted.

Thanks,
Kenny

Comment 10 jcallaha 2016-09-19 19:42:25 UTC
Verified in Satellite 6.1.10.

Created activation keys with user then deleted the user saw that they keys remained. See attached video for another verification attempt.

Comment 11 jcallaha 2016-09-19 19:43:02 UTC
Created attachment 1202621 [details]
verification video

Comment 13 errata-xmlrpc 2016-09-27 09:03:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938


Note You need to log in before you can comment on or make changes to this bug.