Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337910 - [RFE] vCenter Provider : To add the capability of provisioning a VM to a Datastore Cluster without choosing the Datastore
Summary: [RFE] vCenter Provider : To add the capability of provisioning a VM to a Data...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Shveta
URL:
Whiteboard: vsphere:datastore
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-20 12:26 UTC by Andre Motta
Modified: 2017-08-30 01:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:11:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
vCenter Webclient Create VM on target Datastore DRS Cluster without selecting Datastore (auto-recommendation from DS DRS cluster) (512.31 KB, image/tiff)
2016-05-20 12:26 UTC, Andre Motta
no flags Details

Description Andre Motta 2016-05-20 12:26:56 UTC
Created attachment 1159895 [details]
vCenter Webclient Create VM on target Datastore DRS Cluster without selecting Datastore (auto-recommendation from DS DRS cluster)

Description of problem:
In CloudForms 4.1 we inventory Datastore DRS Clusters and have the Datastore and DS DRS cluster relationship mapped although at VM provisioning request we still need to select the target datastore. From vCenter WebClient or C# client we can provision a VM to a Datastore DRS cluster without selecting the target Datastore, which is automatically selected by the Datastore DRS cluster.   

Version-Release number of selected component (if applicable):
5.6.0

How reproducible:
Everytime a VM is provisioned on a Datastore attached to a Datastore cluster.

Steps to Reproduce:
1. Compute/Infrastructure/Virtual Machines/Life-cycle/Request Provision VM
2. Environment Tab
3. Select the target datastore

Actual results:
The target Datastore of the VM is selected at provisioning time.

Expected results:
The Datastore DRS cluster should be selected from CFME and the datastore would not be needed to be selected.

Additional info:
See attached screenshot of the deployment of a VM only selecting the Datastore DRS Cluster.

Comment 2 Andre Motta 2016-05-20 12:45:54 UTC
As far as I understand the target object for the datastore should be a StoragePod:

https://www.vmware.com/support/developer/converter-sdk/conv61_apireference/vim.StoragePod.html

Comment 3 Andre Motta 2016-05-20 13:20:26 UTC
To complete this request, there is a good example of provisioning a VM to a vSphere Storage DRS cluster without selecting the target datastore here: http://www.virtuallyghetto.com/2012/03/vm-provisioning-on-datastore-clusters.html and here: https://github.com/lamw/vghetto-scripts/blob/master/perl/datastoreClusterVMProvisioning.pl
Thanks!

Comment 5 Chris Pelland 2017-08-28 15:11:32 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.