Bug 133792 - Xorg server hangs if no mouse driver exists
Summary: Xorg server hangs if no mouse driver exists
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 14:31 UTC by W. Michael Petullo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 16:52:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of X11 server starting with no kernel mouse driver loaded (28.12 KB, text/plain)
2004-09-27 14:33 UTC, W. Michael Petullo
no flags Details

Description W. Michael Petullo 2004-09-27 14:31:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
I use a custom kernel on a PowerPC-based iBook.  My kernel mouse
driver is built as a module.  If I try to init run level 5 and my
mouse driver has not been loaded the X blanks the screen but does not
load.  At this point, the screen is blank and Ctrl-Alt-Fx will not
change virtual terminals.  The computer is essentially unresponsive.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-3

How reproducible:
Always

Steps to Reproduce:
Try to load the X server without a kernel mouse driver loaded.
    

Actual Results:  Screen blanks and system becomes unresponsive to
keyboard.

Expected Results:  In the past, a message would print informing me
that my X11 server failed to load.  The dialog would give me the
option to view the X11 server log.

Additional info:

Comment 1 W. Michael Petullo 2004-09-27 14:33:16 UTC
Created attachment 104375 [details]
Log of X11 server starting with no kernel mouse driver loaded

Comment 2 W. Michael Petullo 2004-09-27 14:54:30 UTC
The computer continues to respond to ICMP packets when in the frozen
screen state.

Comment 3 Søren Sandmann Pedersen 2004-10-08 15:42:17 UTC
This is just an X.Org bug I think.

Please file a bug report in the X.Org bugzilla located at
http://bugs.freedesktop.org in the "xorg" component. 

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates. 


Comment 4 W. Michael Petullo 2004-10-09 16:32:09 UTC
This issue is now in freedesktop.org's bug tracking system:

http://freedesktop.org/bugzilla/show_bug.cgi?id=1567

Comment 5 W. Michael Petullo 2004-12-01 16:52:32 UTC
This seems to be fixed on my system.  I am still using X.org X11 6.8.1
(but now use Fedora's 6.8.1-19 package -- I track Raw Hide pretty
closely).  My kernel is now 2.6.9, still self-compiled.  So I don't
know what fixed this, but it is now fixed after being broken for quite
some time.


Note You need to log in before you can comment on or make changes to this bug.