Bug 1337969 - RHELSA kernel hangs in qemu when running 'sgdisk /dev/sda -U R'
Summary: RHELSA kernel hangs in qemu when running 'sgdisk /dev/sda -U R'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-aarch64
Version: 7.3
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2016-05-20 15:04 UTC by Richard W.M. Jones
Modified: 2016-05-23 21:41 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 21:41:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
output from reproducer command (45.26 KB, text/plain)
2016-05-20 15:04 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2016-05-20 15:04:07 UTC
Created attachment 1159979 [details]
output from reproducer command

Description of problem:

The RHELSA kernel hangs when running the command `sgdisk /dev/sda -U R'
apparently when rereading the partition table.  Note I am running
the kernel under qemu.

A one line reproducer for this is:

$ guestfish -N disk part-disk /dev/sda gpt : debug sh "sgdisk /dev/sda -U R" -v -x

The output from this command is attached.

Version-Release number of selected component (if applicable):

kernel-4.5.0-0.38.el7.aarch64

How reproducible:

100%

Steps to Reproduce:
1. See one line reproducer above.

Comment 2 Tom Coughlan 2016-05-23 21:29:00 UTC
I tried the command on bare metal and it worked as expected. 
Transferring this to the Virt. team.

Comment 3 Richard W.M. Jones 2016-05-23 21:41:07 UTC
Hmm, weirdly now I cannot reproduce it.  Only thing I did was reboot ...


Note You need to log in before you can comment on or make changes to this bug.