This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 133797 - intermittent crash, backtrace hits g_free
intermittent crash, backtrace hits g_free
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-27 12:03 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 16:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2004-09-27 12:03:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
I see this in my xsession errors:
(evolution:4452): Bonobo-CRITICAL **: file bonobo-ui-component.c: line
1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed

And here's the backtrace:

(gdb) bt
#0  0x00adb782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00bc490e in __lll_mutex_lock_wait () from /lib/tls/libc.so.6
#2  0x00b5886f in _L_mutex_lock_39 () from /lib/tls/libc.so.6
#3  0x00000000 in ?? ()
#4  0x00000000 in ?? ()
#5  0x00000000 in ?? ()
#6  0x00d0959c in ?? () from /usr/X11R6/lib/libX11.so.6
#7  0x00c14ff4 in ?? () from /lib/tls/libc.so.6
#8  0x00c176a0 in fork_handler_pool () from /lib/tls/libc.so.6
#9  0x00c176a0 in fork_handler_pool () from /lib/tls/libc.so.6
#10 0xfee81188 in ?? ()
#11 0x00b7c36c in fork () from /lib/tls/libc.so.6
#12 0x00b7c36c in fork () from /lib/tls/libc.so.6
#13 0x00d3d494 in fork () from /lib/tls/libpthread.so.0
#14 0x0388af26 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#15 <signal handler called>
#16 0x00adb782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#17 0x00b1b4a5 in raise () from /lib/tls/libc.so.6
#18 0x00b1ceb9 in abort () from /lib/tls/libc.so.6
#19 0x00b53cab in malloc_printerr () from /lib/tls/libc.so.6
#20 0x00b5473a in free () from /lib/tls/libc.so.6
#21 0x00d6ea71 in g_free () from /usr/lib/libglib-2.0.so.0
#22 0x0035f64c in gtk_label_set_attributes () from
/usr/lib/libgtk-x11-2.0.so.0
#23 0x002ac8fa in gtk_accel_label_new () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x0010c8dc in g_object_unref () from /usr/lib/libgobject-2.0.so.0
#25 0x0010ca17 in g_object_run_dispose () from
/usr/lib/libgobject-2.0.so.0
#26 0x00390e18 in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x004663b3 in gtk_widget_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#28 0x00382b65 in gtk_menu_item_set_accel_path () from
/usr/lib/libgtk-x11-2.0.so.0
#29 0x002f4fcb in gtk_container_foreach () from
/usr/lib/libgtk-x11-2.0.so.0
#30 0x002f72e8 in gtk_container_unset_focus_chain () from
/usr/lib/libgtk-x11-2.0.so.0
#31 0x0038051c in gtk_menu_item_new_with_mnemonic () from
/usr/lib/libgtk-x11-2.0.so.0
#32 0x003a1ce0 in gtk_radio_menu_item_new_with_label_from_widget ()
from /usr/lib/libgtk-x11-2.0.so.0
#33 0x001220ae in g_cclosure_marshal_VOID__VOID () from
/usr/lib/libgobject-2.0.so.0
#34 0x0010a6b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#35 0x0010a347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#36 0x0011fb9d in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#37 0x001219bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#38 0x00121c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#39 0x00390e8d in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#40 0x0046c417 in gtk_widget_get_default_direction () from
/usr/lib/libgtk-x11-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#41 0x0bf271c8 in ?? ()
#42 0x00000001 in ?? ()
#43 0x0046c3eb in gtk_widget_get_default_direction () from
/usr/lib/libgtk-x11-2.0.so.0
#44 0x0bf271c8 in ?? ()
#45 0xfee81eb8 in ?? ()
#46 0x0010ca0f in g_object_run_dispose () from
/usr/lib/libgobject-2.0.so.0
Previous frame inner to this frame (corrupt stack?)


Version-Release number of selected component (if applicable):
evolution-2.0.0-2

How reproducible:
Sometimes

Steps to Reproduce:
I can't really pin this down to anything specific.  I get hangs
occasionally when just reading email, or evolution could be hung when
I switch back to it from another desktop.

Additional info:
Comment 1 Dave Malcolm 2004-10-05 13:52:08 EDT
Thanks for the report.  There was a specific bug in libbonoboui that
caused various crashes and similar-looking error output.  Please
confirm which version of libbonoboui you're running. 

If Evolution is hanging, please do a "thread apply all backtrace" (or
"t a a bt") when submitting backtraces since the UI thread might be
blocking on something locked in another thread.

Other than that, perhaps the heap has become corrupted, hence the
crash in g_free.  Would you consider running Evolution under valgrind?

Comment 2 Colin Walters 2004-10-15 16:19:07 EDT
Looks fixed to me, closing.  Will reopen later if I keep having trouble, or
alternatively if I just feel like giving you more bugs.

Note You need to log in before you can comment on or make changes to this bug.