Bug 133798 - /dev/raw1394 not present
/dev/raw1394 not present
Status: CLOSED DUPLICATE of bug 163571
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-27 12:10 EDT by Michele Schiavo
Modified: 2015-01-04 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 05:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michele Schiavo 2004-09-27 12:10:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
/dev/raw1394 is not present.
i try to load /unload module but /dev/raw1394 not present.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.nothing, /dev/raw1394 not present
2.
3.
    

Additional info:
Comment 1 Harald Hoyer 2004-09-29 04:46:29 EDT
unload? you meant, try to load the modules?
Comment 2 Michele Schiavo 2004-09-29 07:25:30 EDT
[root@micyud michele]# /sbin/lsmod | grep 1394
ohci1394               32729  0
ieee1394              285429  1 ohci1394

ll /dev/raw*
ls: /dev/raw*: No such file or directory


[root@micyud michele]# uname -a
Linux micyud.local 2.6.8-1.541smp #1 SMP Wed Sep 1 18:15:33 EDT 2004
i686 i686 i386 GNU/Linux

FC3T2 update devel at 28.09.2004
Comment 3 Michele Schiavo 2004-09-29 07:29:50 EDT
/sbin/rmmod ohci1394
/sbin/rmmod ieee1394
/sbin/modprobe ohci1394
/sbin/modprobe ieee1394
/sbin/lsmod | grep 1394
ohci1394               32729  0
ieee1394              285429  1 ohci1394

dmesg
....
ieee1394: Node removed: ID:BUS[0-00:1023]  GUID[00e01800005b99cd]
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI interrupt 0000:03:03.0[A] -> GSI 20 (level, low) -> IRQ 209
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[209] 
MMIO=[feaff800-feafffff]  Max Packet=[2048]
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00e01800005b99cd]


ll /dev/raw*
ls: /dev/raw*: No such file or directory



Comment 4 Harald Hoyer 2004-09-29 08:04:15 EDT
how about:
# /sbin/modprobe raw1394
# tail -1 /var/log/messages
Sep 29 14:03:54 jever kernel: ieee1394: raw1394: /dev/raw1394 device
initialized

but, you are right, there is no entry in /sys
Comment 5 Harald Hoyer 2004-09-29 08:37:13 EDT
what does 
$ ls /sys/class/ieee1394*

display after loading raw1394 ??
Comment 6 Harald Hoyer 2004-09-29 09:34:13 EDT
nothing in drivers/ieee1394/ seems to create a "dev" class attribute
for sysfs, so udev cannot do much about it...
Comment 7 Michele Schiavo 2004-09-30 15:52:29 EDT
tail -1 /var/log/messages
Sep 30 21:52:35 micyud kernel: ieee1394: raw1394: /dev/raw1394 device
initialized
[root@micyud michele]# ll /dev/raw*
ls: /dev/raw*: No such file or directory
[root@micyud michele]# ls /sys/class/ieee1394*
/sys/class/ieee1394:

/sys/class/ieee1394_host:
fw-host0

/sys/class/ieee1394_node:
00e01800005b99cd
[root@micyud michele]#


looking in /dev without a normal boot i see this directory is empty....

i think udev don't create /dev/raw1394

.........................


[root@micyud michele]# more /etc/udev/udev.conf
# udev.conf
# The main config file for udev
#
# This file can be used to override some of udev's default values
# for where it looks for files, and where it places device nodes.

# udev_root - where in the filesystem to place the device nodes
udev_root="/dev/"

# udev_db - The name and location of the udev database.
udev_db="/dev/.udev.tdb"

# udev_rules - The name and location of the udev rules file
udev_rules="/etc/udev/rules.d/"

# udev_permissions - The name and location of the udev permission file
udev_permissions="/etc/udev/permissions.d/"

# default_mode - set the default mode for all nodes that have no
#                explicit match in the permissions file
default_mode="0600"

# default_owner - set the default owner for all nodes that have no
#                 explicit match in the permissions file
default_owner="root"

# default_group - set the default group for all nodes that have no
#                 explicit match in the permissions file
default_group="root"

# udev_log - set to "yes" if you want logging, else "no"
udev_log="yes"

####################################################
# Additional configuration options added by Red Hat
####################################################

# udev_owner - preserve the ownership, if the device node is already there
udev_preserve_owner="no"

# udev_remove - remove created device nodes, if the device is removed
#               symlinks will be removed no matter what
udev_remove_devicenodes="no"

#
# Variables in uppercase are for the scripts only
#

# set USE_UDEV to yes, if you want to use udev
USE_UDEV="yes"

# if selinux file attributes
# should be restored (leave to yes, if unsure)
UDEV_SELINUX="yes"

# if console permissions (pam_console)
# should be restored (leave to yes, if unsure)
UDEV_CONSOLE="yes"

# if dbus messages should be sent
UDEV_DBUS="no"

# if shell script actions should be logged
UDEV_LOG="yes"

# if tmpfs should be mounted over the udev_root
# automatically yes, if UDEV_KEEP_DEV=yes and UDEV_INITRD=yes

# WARNING: IF YOU SET THIS TO NO, YOUR SYSTEM WILL BREAK
# DO NOT DO SO UNLESS YOU KNOW WHAT YOU'RE DOING
UDEV_TMPFS="yes"

# if udev should be used in initrd
UDEV_INITRD="yes"

# if the initrd tmpfs udev_root should be used
UDEV_KEEP_DEV="yes"

# for backwards compatibility
UDEV_RAMFS="$UDEV_TMPFS"
Comment 8 Michele Schiavo 2004-10-02 06:53:02 EDT
PARTIAL SOLVED 

At boot time i type :

modprobe raw1394
mknod -m 666 /dev/raw1394 c 171 0



lsmod | grep 1394
raw1394                26669  0
ohci1394               31065  0
ieee1394              285941  2 raw1394,ohci1394

ll /dev/raw*
crw-rw-rw-  1 root root 171, 0 Oct  2 11:14 /dev/raw1394
Comment 9 Matthias Saou 2004-11-19 14:57:25 EST
Same problem here : plugged in my DV camera, ran "dvgrab" with the
proper arguments as usual (on FC2), but it failed. Running "MAKEDEV
raw1394" fixes the problem temporarily by creating the missing /dev
entry (only until the next reboot, obviously).

I guess this /dev entry, as well as /dev/video1394/[1-4] possibly,
need to be created somehow and somewhen. When ohci1394 or ieee1394 get
loaded?
Comment 10 Jon Smirl 2005-01-22 22:18:16 EST
I can comfirm this. The raw1394 and video1394 device drivers are not
exporting a dev file in sysfs so udev won't make a /dev file for them.
There was a patch for this on lkml but it doesn't look like it was
accepted. This is a problem with the kernel drivers for 1394, not a
udev problem. Still broken in Linus 2.6.11-rc2

Work around:
MAKEDEV video1394 raw1394
Comment 12 Jody McIntyre 2005-02-04 13:34:42 EST
It's in -rc3-mm1.  I have produced patches against 2.6.10-ac11:

http://www.modernduck.com/1394-patches/sysfs-2.6.10-ac11-1.patch
http://www.modernduck.com/1394-patches/sysfs-2.6.10-ac11-2.patch
http://www.modernduck.com/1394-patches/sysfs-2.6.10-ac11-3.patch

They also apply to 2.6.10 and should work, but I only compile tested.

It should appear in Linus kernels early in 2.6.12.
Comment 13 Christian Schaller 2005-04-15 06:09:40 EDT
Harald, would it be possible to have these patches backported and included in
Fedora, would be nice if Firewire worked out the box in FC4.
Comment 14 Wayne Schuller 2005-04-15 07:04:10 EDT
yes get it in the FC4 kernel (and next FC 3 kernel update) please - this felt
like a big feature regression for us linux video editing types. :)
Comment 15 Harald Hoyer 2005-04-27 05:42:04 EDT
udev != kernel ... reassigning
Comment 16 Dave Jones 2005-05-01 04:23:50 EDT
merged into CVS, will be in the next update.

Thanks.
Comment 17 Christian Schaller 2005-07-21 13:38:06 EDT
Was this only merged into a FC3 update? Cause I still have the problem with
latest  FC4 kernel.
Comment 18 Wayne Schuller 2005-08-07 02:27:02 EDT
I still have the problem with the latest fc4 kernel also.
Comment 19 Walter Justen 2005-08-25 05:57:45 EDT
Thanks for the bug report. This particular bug has already been reported (for FC4)
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 163571 ***

Note You need to log in before you can comment on or make changes to this bug.