Bug 1337984 - BackupPC expects /var/run/BackupPC to exist which doesn't after a reboot
Summary: BackupPC expects /var/run/BackupPC to exist which doesn't after a reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: BackupPC
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Lefoul
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-20 15:34 UTC by Ollie Armstrong
Modified: 2016-07-18 18:49 UTC (History)
2 users (show)

Fixed In Version: BackupPC-3.3.1-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 18:49:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Ollie Armstrong 2016-05-20 15:34:54 UTC
Description of problem:
/var/run is a symlink to /run, which is mounted as tmpfs on RHEL 7. This means that /var/run/BackupPC (which is created when installing the RPM) is lost after a reboot and BackupPC fails to start.


Version-Release number of selected component (if applicable): 3.3.1-1.el7


How reproducible: always


Steps to Reproduce:
1. Install BackupPC
2. Reboot


Actual results:
systemctl start backuppc fails because /var/run/BackupPC doesn't exist. An error message is logged to /var/log/BackupPC/LOG about being unable to create a socket.


Expected results:
/var/run/BackupPC exists and BackupPC is able to start.


Additional info:
I've added the line

mkdir -p /var/run/BackupPC && chown backuppc:backuppc /var/run/BackupPC

to /etc/rc.d/init.d/backuppc at line number 55 which solves the issue for me. There is probably a better way of doing this.

Comment 1 Fedora Update System 2016-06-30 07:15:04 UTC
BackupPC-3.3.1-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e3110a7ad

Comment 2 Fedora Update System 2016-06-30 22:18:37 UTC
BackupPC-3.3.1-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e3110a7ad

Comment 3 Fedora Update System 2016-07-18 18:49:43 UTC
BackupPC-3.3.1-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.