Bug 1338001 - there are 3 different implementations of Accept Host work flow, of which only one follows expected design
Summary: there are 3 different implementations of Accept Host work flow, of which only...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2
Assignee: Soumya Deb
QA Contact: Martin Bukatovic
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-20 16:30 UTC by Martin Bukatovic
Modified: 2016-08-23 19:51 UTC (History)
9 users (show)

Fixed In Version: rhscon-ui-0.0.48-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:51:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of variant 2.1 (137.63 KB, image/png)
2016-05-20 16:41 UTC, Martin Bukatovic
no flags Details
screenshot of variant 2.2 (106.01 KB, image/png)
2016-05-20 16:42 UTC, Martin Bukatovic
no flags Details
screenshot of variant 2.3 (235.92 KB, image/png)
2016-05-20 16:42 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1337965 None CLOSED Accept node process is reported as done while Initialize node task is still running 2019-07-31 08:42:03 UTC
Red Hat Bugzilla 1340502 None CLOSED no UI feedback when clicking on "Re-Initialize" button on "View and Accept Hosts" page 2019-07-31 08:42:03 UTC
Red Hat Bugzilla 1340506 None CLOSED state of "View and Accept Hosts" page is lost on reload 2019-07-31 08:42:03 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1337965 1340502 1340506

Description Martin Bukatovic 2016-05-20 16:30:22 UTC
Description of problem
======================

There are 3 different implementation of Accept Host work flow, of which only
one provides full functionality (as specified in the design documents). On the
other hand the other 2 implementations are missing important features and
contains additional bugs. Moreover the proper implementation is the least
visible.

Version-Release
===============

rhscon-ui-0.0.31-1.el7scon.noarch

Related:

rhscon-core-0.0.18-1.el7scon.x86_64
rhscon-ceph-0.0.15-1.el7scon.x86_64
rhscon-agent-0.0.7-1.el7scon.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

Do this 3 times, each time using different variant of step 2.

1. Install RHSC 2.0 following the documentation, make sure you have few nodes
   ready to be accepted later.
2. Accept all nodes via:

2.1 Click on the "Discovered Hosts" icon in the left part of the top menubar,
    and click on "Accept All" button there.

2.2 Click on the "Discovered Hosts" icon in the left part of the top menubar,
    click on "See All" button and then click on "Accept All" button.

2.3 Go to Clusters page, click on "Create Cluster". Modal window with warning
    stating "Unaccepted Hosts Detected" should be shown. Click on "View and
    Accept" button to go to "View and Accept Hosts" page, where you click
    on "Accept All" button.

Actual results
==============

Variants 2.1 and 2.2 doesn't provide required features such as:

 * proper status which takes into account both tasks (accept task and
   initialize task), so that these variants are susceptible to BZ 1337965
 * possibility to notice an error during initialize tasks
 * way to rerun initialization task in case of it's failure (reinitialize
   button)
 * link to task detail page of given host

Also note that such design choices as used in 2.1 and 2.2 are nowhere to be
found in any design document.

Variant 2.3 is the only one which seems to provide all required features and so
it's not affected by BZ 1337965.

Variant 2.3 is available only from the Create Cluster wizard, which makes it
hard to find later again.

Expected results
================

Both link from "Discovered Hosts" icon in the left part of the top menu bar
and "Unaccepted Hosts Detected" modal window of "Create Cluster" wizard should
link to the same "View and Accept Hosts" page, so that:

 * in all cases, the same full implementation of accept host workflow is used
 * it's possible to go back to "View and Accept Hosts" page later after the
   cluster has been created

Additional info
===============

See details of proposed design in the following documents:

 * USM Get Started
 * USM 1.0 Design
 * Create Cluster Workflow
 * Tasks and Events

Comment 2 Martin Bukatovic 2016-05-20 16:41:49 UTC
Created attachment 1160012 [details]
screenshot of variant 2.1

Attaching screenshot of variant from step 2.1

Comment 3 Martin Bukatovic 2016-05-20 16:42:16 UTC
Created attachment 1160013 [details]
screenshot of variant 2.2

Attaching screenshot of variant from step 2.2

Comment 4 Martin Bukatovic 2016-05-20 16:42:41 UTC
Created attachment 1160014 [details]
screenshot of variant 2.3

Attaching screenshot of variant from step 2.3

Comment 5 Martin Bukatovic 2016-06-06 11:10:40 UTC
What does design team thinks about this issue?

Comment 6 Matt Carrano 2016-06-06 21:10:17 UTC
Yes, we agree with Martin.  When clicking on the View All or Accept All links from the Discovered Hosts queue in the menu bar, the user should be taken to a view that has equivalent functionality to the View and Accept Hosts page in the Create Cluster flow.  That page is shown in the design document here: 

https://docs.google.com/a/redhat.com/presentation/d/1E7ZHHMYufugMjuVceluP7FCfUM9CQNsN5QWmGruRth0/edit?usp=sharing

See slide 27.

It should also be possible to get back to this view through the Hosts list view as shown.  This would resolve the various issues related to this bug.

Comment 7 Shubhendu Tripathi 2016-06-09 09:46:28 UTC
We suggest to go to same screen of host acceptance page which comes as part of create cluster flow in below cases

1. User clicks top right corner "Discovered hosts" menu and the selects "Accept All"
2. User clicks top right corner "Discovered hosts" menu and selects "See All"

Also in addition to this we would remove the "Accept" button against each discovered hosts and user needs to selecte either of "Accept All" or "See All" to go to the screen where its shows the status of acceptance/initialization of hosts.

Comment 8 Matt Carrano 2016-06-09 14:28:56 UTC
This sounds like a good solution.

Comment 9 :Deb 2016-06-23 13:36:20 UTC
From what I understand, the modal from the nav-bar button isn't bringing in any usefulness, and only hiding the actual action under one-more-click.

Wouldn't it be rather better to allow user to directly go to the accept host page (instead of click on host discovery -> click on either of the 2 button at the bottom of the modal, both of which leads to the same page)?

So essentially, you click on the navbar button of "Host Discovery" and go to the Accept Hosts page (instead of getting the modal).

Submitted the patch: https://review.gerrithub.io/281571

What changes:
1. If you're coming from Create Cluster page, then nothing changes.
2. If you were to click on accept all hosts in the navbar modal, then it's the same amount of interaction.
3. If you were to click on view all hosts and then decide whether to accept or not, then one less click to get to the same end.

Hope UXD team sees value in my proposition.

Comment 10 Matt Carrano 2016-06-23 15:21:02 UTC
I see your point.  Removing the pop-up dialog triggered from the nav-bar would eliminate a mouse-click.  That said, the value of the dialog is to see a preview of discovered hosts without leaving the current page (same as for Tasks and Events). The user can then decide whether they want to proceed with accepting the hosts and leave the page they are on.  It also keeps this consistent with the behavior of other items in the nav-bar.  So there are valid arguments either way.

My recommendation is to leave the dialog in place for now and we can revisit for the next release.

Comment 11 Ju Lim 2016-06-24 02:32:06 UTC
+1 to leaving dialog in place for now and revisiting for the next release.

Comment 12 :Deb 2016-06-24 11:56:59 UTC
Alright, nothing to do here then.
Please update the flags accordingly, I'm releasing this from myself.

Comment 13 Martin Bukatovic 2016-07-15 11:09:44 UTC
I see this implemented in rhscon-ui-0.0.48-1.el7scon.noarch, should I test it
or ignore it (assuming that it will be changed somehow again in next build?).
I'm confused because in was added into GA tracker during one of the bug scrub
meetings and I'm not aware of any updates here.

Comment 14 Martin Bukatovic 2016-07-15 16:01:08 UTC
Testing with:

rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch

With this build, one can reach only a single implementation of "View and Accept
Hosts" page in 2 different ways:

 * Click on "Host Discovery" icon in the top menubar brings user to 
   "View and Accept Hosts" page directly (eliminating the popup menu and 2
   different ways and implementation of accept host dialogs).
   In this case, there is no "continue" button (which is shown only during
   create cluster wizard)
 * Via "Unaccepted Hosts Detected" modal window shown when one starts "Create
   Cluster" wizard when RHSC 2.0 has detected some unaccepted hosts. 

When all hosts are accepted, one can no longer reach this page during Create
Cluster wizard, but when one clicks on "Hosts Discovery" icon, the page is
shown reporting "0 of 0 hosts accepted (0 in progress)".

>> VERIFIED

Just for a record, related issue BZ 1340506 remains unfixed.

Comment 16 errata-xmlrpc 2016-08-23 19:51:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.