Bug 1338010 - fedora-bookmarks don't show up in Firefox
Summary: fedora-bookmarks don't show up in Firefox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F24FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-05-20 17:18 UTC by Paul W. Frields
Modified: 2017-04-26 18:56 UTC (History)
15 users (show)

Fixed In Version: firefox-47.0-4.fc24 firefox-47.0-4.fc23 firefox-47.0-4.fc22
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-09 14:08:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1343740 0 unspecified CLOSED Transaction check error default-bookmarks conflicts with fedora-bookmarks and astronomy-bookmarks 2021-02-22 00:41:40 UTC

Internal Links: 1343740

Description Paul W. Frields 2016-05-20 17:18:29 UTC
While testing a new build of fedora-bookmarks, I discovered that, though valid, the Fedora bookmarks don't appear in the bookmark tree in a brand new account and Firefox profile.  I'm asking for some help to figure out why, and quickly, since the Final Freeze happens May 31.

I'm happy to help from the fedora-bookmarks packaging side if this turns out to be a problem with the bookmark content, and not something that's changed on the Firefox side.

Comment 1 Martin Stransky 2016-05-23 09:12:46 UTC
That's because fedora-bookmarks is BuildRequires - used only when the package is composed and the bookmark file is packages inside firefox data file. I'll update spec to make it clear. We have to rebuild Firefox anyway so that should be fixed soon.

Comment 2 Martin Stransky 2016-05-23 09:51:59 UTC
New build (46.0.1-7) is in koji now.

Comment 3 Paul W. Frields 2016-05-23 13:48:25 UTC
Reopening -- I don't think the rebuild is the issue.  Using either the previous build, or the new 46.0.1-7 build, I did the following:

1. useradd a new account
2. login as new account
3. open Firefox and then Show All Bookmarks

The Fedora bookmarks don't appear anywhere in the listings.  I do have fedora-bookmarks-24-1.fc24 installed.  If there's something else I should be doing to reproduce proper behavior, let me know.

Is there some other change in Firefox that would result in the bookmarks not being picked up?

Comment 4 Martin Stransky 2016-05-24 10:58:58 UTC
Okay I'll check that. Btw. you don't need to create new user - new profile is enough ($firefox -ProfileManager -no-remote)

Comment 5 Martin Stransky 2016-05-24 13:40:55 UTC
New build - firefox-46.0.1-8 - should fix that.

Comment 6 Paul W. Frields 2016-05-24 19:25:26 UTC
Hi Martin, thanks for the build.  Unfortunately, the new build appears to use the content of astronomy-bookmarks instead of fedora-bookmarks.  Maybe that one is "winning" the Requires because it comes first alphabetically?

Comment 7 Martin Stransky 2016-05-25 08:34:37 UTC
That must be something broken in koji build setup. See the root log:

https://kojipkgs.fedoraproject.org//packages/firefox/46.0.1/8.fc24/data/logs/x86_64/root.log

fedora-bookmarks is not installed but astronomy-bookmarks is. Firefox has BuildRequires: system-bookmarks which can be any package what provides that and allows to build various spins with different ones.

I see that fedora-bookmarks also provides "system-bookmarks" so this is a problem with build config rather than Firefox itself.

Comment 8 Dennis Gilmore 2016-05-25 13:15:26 UTC
so this is not supposed to be a build time thing, but a runtime one. users should get the bookmarks set by what is installed, this is to allow  spins and different versions of fedora to have a different set of bookmarks.  so there is a bug in firefox if its hardcoded in at buildtime.  a ugly bandaid would be to BuildRequire: fedora-bookmarks temporarily. however firefox needs to pick up at runtime based on whatever package providing system-bookmarks is installed.

Comment 9 Martin Stransky 2016-05-25 13:26:07 UTC
(In reply to Dennis Gilmore from comment #8)
> so this is not supposed to be a build time thing, but a runtime one. users
> should get the bookmarks set by what is installed, this is to allow  spins
> and different versions of fedora to have a different set of bookmarks.  so
> there is a bug in firefox if its hardcoded in at buildtime.  a ugly bandaid
> would be to BuildRequire: fedora-bookmarks temporarily. however firefox
> needs to pick up at runtime based on whatever package providing
> system-bookmarks is installed.

Okay, but that's more feature request than a bug - we use the bookmarks this way since ever. We surely can work on that to pick bookmarks runtime, but it's a different issue.

Why does it troubles us right now and was working before? Does the composition process changed or so?

Comment 10 Dennis Gilmore 2016-05-25 13:48:40 UTC
(In reply to Martin Stransky from comment #9)
> (In reply to Dennis Gilmore from comment #8)
> > so this is not supposed to be a build time thing, but a runtime one. users
> > should get the bookmarks set by what is installed, this is to allow  spins
> > and different versions of fedora to have a different set of bookmarks.  so
> > there is a bug in firefox if its hardcoded in at buildtime.  a ugly bandaid
> > would be to BuildRequire: fedora-bookmarks temporarily. however firefox
> > needs to pick up at runtime based on whatever package providing
> > system-bookmarks is installed.
> 
> Okay, but that's more feature request than a bug - we use the bookmarks this
> way since ever. We surely can work on that to pick bookmarks runtime, but
> it's a different issue.
> 
> Why does it troubles us right now and was working before? Does the
> composition process changed or so?

It is a regression not a feature Request. when the system was setup that is how it worked. 

I am having trouble finding details but the astronomy-bookmarks review has some https://bugzilla.redhat.com/show_bug.cgi?id=432265

I suspect that what changed is firefox's behaviour

Comment 11 Paul W. Frields 2016-05-25 15:57:29 UTC
I've found a solution that should solve our problem and simplify Martin's work as well.  As of ~v45, there is a "distribution.ini" file that allows runtime additions to bookmarks, extensions/add-ons, etc.:

https://wiki.mozilla.org/Distribution_INI_File

We want to solve for four goals, as I see it:
(1) Allow spins to include their own custom bookmarks
(2) Preserve the remixability of Fedora
(3) Avoid dragging in the wrong custom bookmarks for the general Firefox build
(4) Solve similarly for related browsers (icecat, seamonkey currently)

Proposed solution:

(1) Astronomy spin updates (adding maintainer to CC)
   (a) rework astronomy-bookmarks content as a distribution.ini file
      (i) write file into %{_sharedir}/bookmarks/distribution.ini
   (b) drops the "Provides: system-bookmarks" in its spec file
   (c) add scriptlet 
   (d) add astronomy-bookmarks to the spin kickstart explicitly
   (Astronomy is the only spin doing this, but future spins could do likewise)

(2) Firefox package updates
   (a) package a symlink %{_libdir}/firefox/distribution/distribution.ini -> %{_sharedir)/bookmarks/distribution.ini

Solved:
* In the case of a standard Fedora edition, fedora-bookmarks should be included automatically in the build of Firefox.
* In the case of a spin, their specific bookmarks will be added to the Fedora bookmarks -- no need to choose between syncing bookmarks or replacing
* It's not clear icecat or seamonkey have the distribution.ini capability, but that would be a downstream problem; if a spin decides to use it as default, should be able to handle via a new *-bookmarks and kickstart
* Remixers can still similarly use their own system-bookmarks providing package


Does this sound reasonable?

Comment 12 Martin Stransky 2016-05-26 07:56:30 UTC
(In reply to Paul W. Frields from comment #11)
> Does this sound reasonable?

Sure, I don't have any problem with that if it works for you. Let me know when the bookmarks are updated so we can rebuild Firefox for that.

Comment 13 Paul W. Frields 2016-05-26 14:44:46 UTC
Also, sorry for erroneous (1)(c) in the above proposal.  It can be ignored.

Comment 14 Christian Dersch 2016-05-27 08:03:44 UTC
I removed astronomy-bookmarks from the spin due to this issue, it is also outdated. (I'm not the maintainer of this package)

https://pagure.io/fedora-kickstarts/pull-request/12
https://pagure.io/fedora-kickstarts/pull-request/13

Comment 15 Martin Stransky 2016-05-27 08:20:28 UTC
The astronomy-bookmarks needs to be updated for the distribution.ini or removed from build roots. Both approaches fixes this bug.

Comment 16 Paul W. Frields 2016-05-31 14:28:21 UTC
I added the owner of astronomy-bookmarks, thought that was lupinix but was wrong. Since the bookmarks are quite outdated, and are removed from the spin, we should ask Marek to at least do (1)(b) above (drop Provides:system-bookmarks, rebuild and issue update).

Comment 17 Martin Stransky 2016-06-01 06:57:40 UTC
Guys, any decision here? Shall I rebuild the astronomy-bookmarks or is someone else going to do so? New Firefox update (47) is coming out next Tuesday, will be good to have correct bookmarks there.

Comment 18 Paul W. Frields 2016-06-01 18:45:22 UTC
Thanks for the update, Martin.  I talked to Marek (mmahut) yesterday.  He was going to rebuild astronomy-bookmarks last night removing the Provides:, so you could rebuild Firefox and get the expected results.  Marek, can you do that soon please?

Comment 19 Chris Murphy 2016-06-04 00:44:23 UTC
+1 FE for either the update or remove method to fix this.

Comment 20 Greg` 2016-06-04 00:50:21 UTC
any New News on this? i have Firefox 47 installed atm but still no Fedora Bookmarks

Comment 21 Martin Stransky 2016-06-06 09:30:56 UTC
An updated package is here - astronomy-bookmarks-1-15.fc24

Comment 22 Martin Stransky 2016-06-06 09:40:42 UTC
Fedora update is here:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bbd673d3

Build root tag request is here:
$ koji wait-repo f24-build --build=astronomy-bookmarks-1-15.fc24

Comment 23 Martin Stransky 2016-06-06 09:53:55 UTC
firefox-47.0-4.fc24 should contain correct bookmarks.

Comment 24 Martin Stransky 2016-06-06 13:57:35 UTC
firefox-47.0-4.fc24 seems to have correct bookmarks.

Comment 25 Adam Williamson 2016-06-06 17:29:47 UTC
No firefox build since 46.0.1-4 has been submitted as an update, it seems. That makes it a bit difficult to take this as an FE as it'd be rolling up a substantial amount of untested change, including a version bump...

Comment 26 Geoffrey Marr 2016-06-06 19:30:05 UTC
This bug was discussed at the 2016-06-06 blocker review meeting [1] and determined to be an AcceptedFreezeException as it is good to keep Fedora branding in the release, however it is noted that there are other changes in the latest Firefox release that will need to be tested.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-06-06/f24-blocker-review.2016-06-06-16.00.txt

Comment 27 Joachim Backes 2016-06-07 07:22:34 UTC
Upgrading fails:
-----------------------

Last metadata expiration check: 2:05:29 ago on Tue Jun  7 07:11:25 2016.
Dependencies resolved.
================================================================================
 Package                  Arch        Version        Repository            Size
================================================================================
Installing:
 fedora-bookmarks         noarch      24-1.fc24      fedora                11 k
Upgrading:
 astronomy-bookmarks      noarch      1-15.fc24      updates-testing       10 k

Transaction Summary
================================================================================
Install  1 Package
Upgrade  1 Package

Total download size: 22 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): astronomy-bookmarks-1-15.fc24.noarch.rpm 175 kB/s |  10 kB     00:00    
(2/2): fedora-bookmarks-24-1.fc24.noarch.rpm     58 kB/s |  11 kB     00:00    
--------------------------------------------------------------------------------
Total                                            11 kB/s |  22 kB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/bookmarks/default-bookmarks.html conflicts between attempted installs of fedora-bookmarks-24-1.fc24.noarch and astronomy-bookmarks-1-15.fc24.noarch

Comment 28 Fedora Update System 2016-06-07 10:12:32 UTC
firefox-47.0-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-559fb75a4c

Comment 29 Fedora Update System 2016-06-07 10:12:38 UTC
firefox-47.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7c55ce2fa

Comment 30 Fedora Update System 2016-06-07 10:12:45 UTC
firefox-47.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f89d347ad6

Comment 31 Martin Stransky 2016-06-07 11:35:50 UTC
An updated bookmark package which fixes this one is here:
https://bodhi.fedoraproject.org/updates/astronomy-bookmarks-1-16.fc24

New Firefox update (47.0) with fixed bookmarks is here:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7c55ce2fa

Comment 32 Vinicius Reis 2016-06-07 18:31:23 UTC
Same issue as described in #27.

Comment 33 Fedora Update System 2016-06-07 18:53:38 UTC
firefox-47.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a7c55ce2fa

Comment 34 Fedora Update System 2016-06-08 02:23:36 UTC
firefox-47.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f89d347ad6

Comment 35 Fedora Update System 2016-06-08 02:24:08 UTC
firefox-47.0-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-559fb75a4c

Comment 36 Kamil Páral 2016-06-08 09:21:20 UTC
Martin, it seems that astronomy-bookmarks should have been submitted together with firefox in a single update? See bug 1343740.

Adam, when requesting this update to be pushed stable, please be aware that there's a potential situation of breaking the deps. We should figure out whether it's safe to push just firefox stable, or both firefox and astronomy-bookmarks have to go together.

Comment 37 Kamil Páral 2016-06-08 09:49:58 UTC
(In reply to Kamil Páral from comment #36)
> Adam, when requesting this update to be pushed stable, please be aware that
> there's a potential situation of breaking the deps. We should figure out
> whether it's safe to push just firefox stable, or both firefox and
> astronomy-bookmarks have to go together.

I tried this and it seems it is safe to push just firefox stable, or firefox+astronomy-bookmarks stable. The dependency problem appears only if just astronomy-bookmarks are pushed stable and the corresponding firefox is not available.

Comment 38 Martin Stransky 2016-06-08 10:00:11 UTC
(In reply to Kamil Páral from comment #37)
> I tried this and it seems it is safe to push just firefox stable, or
> firefox+astronomy-bookmarks stable. The dependency problem appears only if
> just astronomy-bookmarks are pushed stable and the corresponding firefox is
> not available.

Yes, that's correct, because new Firefox does not contain dependency to system-bookmarks provided by fedora|astronomy-bookmarks. The *-bookmarks dependency is only a build time, not run time.

Comment 39 Adam Williamson 2016-06-08 15:25:53 UTC
How about the seamonkey case reported in the update?

Comment 40 Adam Williamson 2016-06-08 22:07:38 UTC
This was reported verified by multiple folks, at least for firefox + astronomy-bookmarks case.

Comment 41 Fedora Update System 2016-06-08 22:53:09 UTC
firefox-47.0-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 42 Adam Williamson 2016-06-08 22:56:35 UTC
We are tracking this for F24 FE purposes, re-opening.

Comment 43 Fedora Update System 2016-06-09 14:08:36 UTC
firefox-47.0-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 44 Fedora Update System 2016-06-10 02:19:41 UTC
firefox-47.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 45 abkahrs 2017-04-26 14:50:42 UTC
Martin,
I am working on a Fedora Remix (https://github.com/RITlug/TigerOS) and I was wondering if the bookmarks are still pulled at build time and embedded in Firefox. I would like to add custom bookmarks to the remix but adding the tigeros-bookmarks package and excluding the fedora-bookmarks package does not seem to have any effect. Is it possible to change the bookmarks at runtime as Dennis mentioned above?

Comment 46 Martin Stransky 2017-04-26 18:56:23 UTC
Yes, it's still build time. I'll happily take a patch which changes that to run-time bookmark pickup but I don't have a time to work on that right now.


Note You need to log in before you can comment on or make changes to this bug.